summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-09-27 13:25:28 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-09-27 13:27:30 -0500
commite96ccd3d636a4af6bfd4c5b86500c5e4ccd30b8a (patch)
tree5f13edc16926e6658336e51da49bbcdbde945c2a
parentdev-util/android-studio: hack around portage deficiency with hard blocker (diff)
downloadgentoo-e96ccd3d.tar.gz
gentoo-e96ccd3d.tar.bz2
gentoo-e96ccd3d.zip
sys-apps/baselayout: install sysctl.d and modprobe.d in /lib on linux
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--sys-apps/baselayout/baselayout-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-apps/baselayout/baselayout-9999.ebuild b/sys-apps/baselayout/baselayout-9999.ebuild
index fd82615d04ae..5df53f3739ae 100644
--- a/sys-apps/baselayout/baselayout-9999.ebuild
+++ b/sys-apps/baselayout/baselayout-9999.ebuild
@@ -244,10 +244,15 @@ src_prepare() {
}
src_install() {
+ dodir /usr/lib
emake \
OS=$(usex kernel_FreeBSD BSD Linux) \
DESTDIR="${ED}" \
install
+ if use kernel_linux; then
+ insinto /lib
+ doins -r lib.Linux/*
+ fi
dodoc ChangeLog
# need the makefile in pkg_preinst