summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-14 02:18:48 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-14 02:26:09 +0200
commite970b4d41822b023a7bb13ee12f130166d0e3e2e (patch)
tree770d1b1b798a26f1f6fa40322e397467f8ca7289
parentmedia-libs/tremor: fix copyright year (diff)
downloadgentoo-e970b4d41822b023a7bb13ee12f130166d0e3e2e.tar.gz
gentoo-e970b4d41822b023a7bb13ee12f130166d0e3e2e.tar.bz2
gentoo-e970b4d41822b023a7bb13ee12f130166d0e3e2e.zip
app-emacs/emacs-aio: new package; add version 1.0_p20200610
2020.06.10 snapshot Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/emacs-aio/Manifest1
-rw-r--r--app-emacs/emacs-aio/emacs-aio-1.0_p20200610.ebuild28
-rw-r--r--app-emacs/emacs-aio/metadata.xml26
3 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/emacs-aio/Manifest b/app-emacs/emacs-aio/Manifest
new file mode 100644
index 000000000000..d14fde226f94
--- /dev/null
+++ b/app-emacs/emacs-aio/Manifest
@@ -0,0 +1 @@
+DIST emacs-aio-1.0_p20200610.tar.gz 9825 BLAKE2B f7d536b5ab603ec0506cf437e9819c00a84678dd1176ea83ac537c112767768a49bf6c95cc135255b252f83b1ecd47b6f195d5c812535f6c3c9843269e2c8750 SHA512 ac4b956a067d52130e57adb8c92bcd733b9566a1f8bfd03f721d7cb1479236346d8c65cf3c6d8475f9f5bb234f0fc766e2954d24af9feff891e1ece6a833c5d9
diff --git a/app-emacs/emacs-aio/emacs-aio-1.0_p20200610.ebuild b/app-emacs/emacs-aio/emacs-aio-1.0_p20200610.ebuild
new file mode 100644
index 000000000000..50a5d7e23baf
--- /dev/null
+++ b/app-emacs/emacs-aio/emacs-aio-1.0_p20200610.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=da93523e235529fa97d6f251319d9e1d6fc24a41
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Async and await functions for Emacs Lisp"
+HOMEPAGE="https://github.com/skeeto/emacs-aio/"
+SRC_URI="https://github.com/skeeto/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+src_compile() {
+ emake EMACS=${EMACS} compile
+}
+
+src_test() {
+ emake EMACS=${EMACS} check
+}
diff --git a/app-emacs/emacs-aio/metadata.xml b/app-emacs/emacs-aio/metadata.xml
new file mode 100644
index 000000000000..07a12f84c7c6
--- /dev/null
+++ b/app-emacs/emacs-aio/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ aio is to Emacs Lisp as asyncio is to Python. This package builds upon
+ Emacs 25 generators to provide functions that pause while they wait on
+ asynchronous events. They do not block any thread while paused. The main
+ components of this package are aio-defun/aio-lambda to define async
+ function, and aio-await to pause these functions while they wait on
+ asynchronous events. When an asynchronous function is paused, the main
+ thread is not blocked. It is no more or less powerful than callbacks, but
+ is nicer to use. This is implementation is based on Emacs 25 generators,
+ and asynchronous functions are actually iterators in disguise, operated as
+ stackless, asymmetric coroutines.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/skeeto/emacs-aio/issues/</bugs-to>
+ <remote-id type="github">skeeto/emacs-aio</remote-id>
+ </upstream>
+</pkgmetadata>