summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-12-06 23:03:37 +0100
committerSam James <sam@gentoo.org>2022-12-15 04:44:00 +0000
commite9983c29e4e051031c78b6570d079aa3a838d40a (patch)
treeaeea2ed0dc2ebdff993ffadb6dcb6689b9de1773
parentnet-analyzer/wtfis: sync live (diff)
downloadgentoo-e9983c29e4e051031c78b6570d079aa3a838d40a.tar.gz
gentoo-e9983c29e4e051031c78b6570d079aa3a838d40a.tar.bz2
gentoo-e9983c29e4e051031c78b6570d079aa3a838d40a.zip
dev-util/ROPgadget: add 7.2
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/28577 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/ROPgadget/Manifest1
-rw-r--r--dev-util/ROPgadget/ROPgadget-7.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/ROPgadget/Manifest b/dev-util/ROPgadget/Manifest
index d568a746dedd..007198d377ec 100644
--- a/dev-util/ROPgadget/Manifest
+++ b/dev-util/ROPgadget/Manifest
@@ -1 +1,2 @@
DIST ROPgadget-7.1.gh.tar.gz 10092729 BLAKE2B dc06e99347987d9eb8b346a6a55599013b7d90b996cbd59f27721f26ce6e59a1ead7c0e3824fdb4fa4d215256d6ad378b2e6eec210561a217b2fa65b2efda169 SHA512 f86956108ba5f131a609026087d4d952cb106ed03e72b04844ae551bdf5902ff70b917bc7c2bcd256591142d4f03e3aef0ceca7ad0d325fb5663f892e27b4b70
+DIST ROPgadget-7.2.gh.tar.gz 10092747 BLAKE2B 1a1de7ce06115c8ffb377d3e7c77a268d3e9a158ed9255c02f954da4a0c32732f741e7ca081fa0b75b9a5dce2fa099b8548f26d248ed0285a2290f88dadc848d SHA512 cc3f87a4a331a3c7799f197b8a9056d1da85697a47c57d03cc080aa61d6c8a00775e7f972082f92451439c36ef9d820c982194464f02ec041b5bbeb97fa26f9a
diff --git a/dev-util/ROPgadget/ROPgadget-7.2.ebuild b/dev-util/ROPgadget/ROPgadget-7.2.ebuild
new file mode 100644
index 000000000000..50c40c36f4b9
--- /dev/null
+++ b/dev-util/ROPgadget/ROPgadget-7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Search for gadgets in binaries to facilitate your ROP exploitation"
+HOMEPAGE="https://shell-storm.org/project/ROPgadget/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/JonathanSalwan/ROPgadget"
+else
+ SRC_URI="https://github.com/JonathanSalwan/ROPgadget/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/capstone-5[python,${PYTHON_USEDEP}]
+"
+
+src_test() {
+ pushd test-suite-binaries || die
+ ./test.sh || die
+ popd || die
+}