summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-01 05:53:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-01 08:53:47 +0200
commite9a6a0e673a93964116948498a922bcb41d8eaca (patch)
tree2c6679897f00462b3c76d1de277f8dceb0d5aa2a
parentdev-ml/ocaml-ctypes: findlib[ocamlopt?] is in findlib.eclass (diff)
downloadgentoo-e9a6a0e6.tar.gz
gentoo-e9a6a0e6.tar.bz2
gentoo-e9a6a0e6.zip
dev-python/botocore: Bump to 1.27.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.21.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d558d4974c8d..7705241255ae 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.27.12.tar.gz 9132872 BLAKE2B 74b74b5a5745cfacac066d5e087974fb58be5a600c7cfb2077d243044b8c429b1396d19e6790c0f754e42931085b115f74039b8c93da39593512d28021d6314a SHA512 767defae44ffb3b54b55625fd0f8a20c22a4a5f209a1397b1a27cfc2e36ac9e03cfdd25bc77bebc944613c5744dd7651e1b574674e8a992f219e172eee9210f5
DIST botocore-1.27.17.tar.gz 9130505 BLAKE2B 04c6b37f3b42a0f9fb696b5213338b004418a68c754f5027ad447119fb20556dc49bd53f40fd9560ea3f5bdcf2afbe151dba68e901079baec770f9f223b1a894 SHA512 b1a145d3c97adfd4df40639da99e1c34087508be189d5818ee7176f20454f2897a6f518a14b4bfbf41cb169a17188bec467337c10d0ad511e223f0c1ff5b64ee
DIST botocore-1.27.20.tar.gz 9146126 BLAKE2B 3ec9e6480fb5bc95f72ffa1f0972b7d9e807fce2e69a3118818a7eba5c1023316c9499bdcbc2f6b2616842eb8797ed0b2bef5ebceee5b74a12074b927b339994 SHA512 1ac0b189e14fb25f07c63e4933113ca64c2bdc53fe719270daccc55b2c7d8ba7421fa81aa60e6fc3a0c86cdb3f57980781388586ce154d87f17f860cc943467a
+DIST botocore-1.27.21.tar.gz 9149425 BLAKE2B fa7141f78128ebc4810bf51bcca93a23606ef611721fd1a32ca490a9e38aef86439385bd7a0465e82a853c5bb7596dffb0b17fc5d7015fb5039f4933ab1554f1 SHA512 59bdf83b237e3845f48685919a6330846d2a4d7ce12d15d99cdb8dd9f2d3e0dcc0d1641c52de8d6d9ef7b7202b80bc59070cb1786f1b38c20884e0fa32481432
diff --git a/dev-python/botocore/botocore-1.27.21.ebuild b/dev-python/botocore/botocore-1.27.21.ebuild
new file mode 100644
index 000000000000..830c713f6036
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.21.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}