summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-11-03 23:29:19 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-11-03 23:37:16 +0100
commite9aa3ce24709f90f3e3c4e2c718c436ab7ea9bc8 (patch)
treeda89934c14436798ec4368f4be21598e7931f472
parentx11-misc/mugshot: migrate to pep517 (diff)
downloadgentoo-e9aa3ce2.tar.gz
gentoo-e9aa3ce2.tar.bz2
gentoo-e9aa3ce2.zip
x11-misc/xflux-gui: add 2.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--x11-misc/xflux-gui/Manifest1
-rw-r--r--x11-misc/xflux-gui/xflux-gui-2.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/xflux-gui/Manifest b/x11-misc/xflux-gui/Manifest
index 920d5083f8cb..f64818024827 100644
--- a/x11-misc/xflux-gui/Manifest
+++ b/x11-misc/xflux-gui/Manifest
@@ -1 +1,2 @@
DIST xflux-gui-1.2.0.tar.gz 31831 BLAKE2B ad6b29f75cf5c287efdb4c1eaa12610a6fd2d4515e7f77cb991f0140d9de1128981ae274a1503f7c5bb83ff84f8dc124ba64e5abdd2e97c1d7157c84df51bead SHA512 244c11efbf58112d3d84209142faafbbe46b33df1edf13e122945ff767fc6a394c147979c0086bd88cb41ee7c80b5bd87016b3e158f3a959f3aca8bda47707d2
+DIST xflux-gui-2.0.tar.gz 35805 BLAKE2B 7a15371d682b31c900f35bebd36e12b70d6095c4cdc9c33f43bad031d72b82d8d3800f7f34f7e31965725dfe075dc6934512eeced98aa685d0023a57dfb61103 SHA512 4a5235feecb06ee95d28d4c05bb710014aea120943b3cbe23f2d2130486de82295891d8211a02e52385edb577da3438dd1c2ba45b209ab4359eb3469df08eade
diff --git a/x11-misc/xflux-gui/xflux-gui-2.0.ebuild b/x11-misc/xflux-gui/xflux-gui-2.0.ebuild
new file mode 100644
index 000000000000..442492423668
--- /dev/null
+++ b/x11-misc/xflux-gui/xflux-gui-2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="A GUI for f.lux"
+HOMEPAGE="https://github.com/xflux-gui/fluxgui/"
+SRC_URI="https://github.com/${PN}/fluxgui/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/fluxgui-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libappindicator:3
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ x11-libs/libXxf86vm
+ x11-misc/xflux
+"
+
+python_compile() {
+ # Don't let the package compiling the schemas,
+ # as this could cause a file collision
+ export DISABLE_GSCHEMAS_COMPILED="true"
+
+ distutils-r1_python_compile
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}