summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2016-04-20 21:36:22 -0700
committerMatt Turner <mattst88@gentoo.org>2016-04-20 21:36:53 -0700
commite9e21224c3cba0617b8b9d0e5a8cc7636b0412d1 (patch)
treed493e25b46c8ff21b9fa363bf4c26706254fa016
parentdev-python/gcs-oauth2-boto-plugin: fix SocksiPy-branch reference for bug 577892 (diff)
downloadgentoo-e9e21224c3cba0617b8b9d0e5a8cc7636b0412d1.tar.gz
gentoo-e9e21224c3cba0617b8b9d0e5a8cc7636b0412d1.tar.bz2
gentoo-e9e21224c3cba0617b8b9d0e5a8cc7636b0412d1.zip
media-libs/mesa: Add valgrind USE flag.
-rw-r--r--media-libs/mesa/mesa-9999.ebuild6
-rw-r--r--media-libs/mesa/metadata.xml1
2 files changed, 5 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 6c2c4ebe96af..00213165a443 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -44,8 +44,8 @@ done
IUSE="${IUSE_VIDEO_CARDS}
bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
- +nptl opencl osmesa pax_kernel openmax pic selinux +udev vaapi vdpau
- wayland xvmc xa kernel_FreeBSD"
+ +nptl opencl osmesa pax_kernel openmax pic selinux +udev vaapi valgrind
+ vdpau wayland xvmc xa kernel_FreeBSD"
REQUIRED_USE="
d3d9? ( dri3 gallium )
@@ -148,6 +148,7 @@ DEPEND="${RDEPEND}
)
sys-devel/gettext
virtual/pkgconfig
+ valgrind? ( dev-util/valgrind )
>=x11-proto/dri2proto-2.8-r1:=[${MULTILIB_USEDEP}]
dri3? (
>=x11-proto/dri3proto-1.0:=[${MULTILIB_USEDEP}]
@@ -299,6 +300,7 @@ multilib_src_configure() {
$(use_enable gles2) \
$(use_enable nptl glx-tls) \
$(use_enable !udev sysfs) \
+ --enable-valgrind=$(usex valgrind auto no) \
--enable-llvm-shared-libs \
--with-dri-drivers=${DRI_DRIVERS} \
--with-gallium-drivers=${GALLIUM_DRIVERS} \
diff --git a/media-libs/mesa/metadata.xml b/media-libs/mesa/metadata.xml
index 88120e51f659..cd38cd9042c5 100644
--- a/media-libs/mesa/metadata.xml
+++ b/media-libs/mesa/metadata.xml
@@ -23,6 +23,7 @@
<flag name="osmesa">Build the Mesa library for off-screen rendering.</flag>
<flag name="pax_kernel">Enable if the user plans to run the package under a pax enabled hardened kernel</flag>
<flag name="pic">disable optimized assembly code that is not PIC friendly</flag>
+ <flag name="valgrind">Compile in valgrind memory hints</flag>
<flag name="vdpau">Enable the VDPAU acceleration interface for the Gallium3D Video Layer.</flag>
<flag name="wayland">Enable support for dev-libs/wayland</flag>
<flag name="xa">Enable the XA (X Acceleration) API for Gallium3D.</flag>