summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-06-04 10:50:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-06-04 10:50:28 -0500
commite9e86dd0f676599d27f602c884f50e652ea793e6 (patch)
treede059caf2475059e02981ac7b31b7c39b4817c57
parentdev-python/oslo-middleware: bup, fixing missing dep for bug 580224 (diff)
downloadgentoo-e9e86dd0.tar.gz
gentoo-e9e86dd0.tar.bz2
gentoo-e9e86dd0.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.2.28
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.5.1.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index e6ea14900b8c..9b40c2eaac40 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_1.4.2-1wheezy_amd64.deb 21510444 SHA256 ee08eab9e50f9afdc979b2
DIST puppet-agent_1.4.2-1wheezy_i386.deb 21254628 SHA256 4683fb7970805a815fe0b500de67e5d1e2b6fa88b19de36cd5326120a2eafdcb SHA512 bac02e08d8d753d6785e6a08c51009ff3ae02e547e942a21177bce6bf97b381a5110d1989fcdae6f3074b9dd9209bd5ff3d01a211f96efb25d24dcf271aa7a26 WHIRLPOOL 742bbcb6f6c55246f7e0f97978919a8d9f3b5f1acfd02e65b13973ffd3a3ebab62a385b0fdfb9076b27dfe2f7b68f25a37724eeec993a6f4c48ec7d145042892
DIST puppet-agent_1.5.0-1xenial_amd64.deb 12958702 SHA256 288bc9cdf318d5a373889e9906f49d96e99c91f996b806e9926469e6adb9afad SHA512 1c6e89b055c8d3937137b91d5f823274f39dcafe9bb65740b17a9d51a37f62d2c6f1a1d52b5f9a8bcdc72880eda158bc7cfe97255b4a4c2a048e71229fb6bb83 WHIRLPOOL c1175cc516f1c9ecc28f97163f9117813415f8011148ece59350b246c39e1b327b8e0a9927914ce8af963020e5a52b3d9839be5c3a0b6a82f242009d9f5999e3
DIST puppet-agent_1.5.0-1xenial_i386.deb 14003222 SHA256 88c4560b1e49f000e0b36ac8a567faa8b1c49c244722cb4bb63e78a6109a21b2 SHA512 b4fd141c481411b08e4b8e65eb28dbd749e5a84bf20070b2fb818fcf34e18828d6c7edc222784f0ae363b07bb634ee12f7114a31b720ef601962dc354b6cd94f WHIRLPOOL ba116eafe5304f8896c510ffd1e42a90e34851ca367e8c82d3570ac7186d63ebca07151e565f8ebfdd33aad16e82698a37aed6f3ce0b679ca4f25e864243d010
+DIST puppet-agent_1.5.1-1xenial_amd64.deb 12981352 SHA256 71bd54296485aeee7bb2e6851904907cee3f31114efa497bf9e999c3a3f15148 SHA512 eabe78c021d70cfea37343daa92b0cb1b1a342c6b8a59e16f83b81d2db8b36e251c44aae7ccd1d6284371e1e50e96ce3d410f1b4481d3f4202ea5904a594a917 WHIRLPOOL dbedf532027091f239bca4eac0fbcb8fb137f76dadc6c0172ceca67a55ef74948a009c978893713277931969d42ef42d6e4bb724490c0b7e67e9eabb0b9f783c
+DIST puppet-agent_1.5.1-1xenial_i386.deb 14023324 SHA256 94509aaa5f03be6e1a73d99585520638f50a582c71d8cfa8432c4f2509907ce4 SHA512 f6c489eec7336388a4ba3ea1c3bcb36e35958b1b1062e9dd4419a68337fbdc2490d775d692830c97fba35a70fbb4c2cb69173643d13a931d011c5b5faf06eff2 WHIRLPOOL 26e4f587af78f3a3bcbb5898416d2aafdb4f1fccf73eb8cab2edf955c8f7a574ea293fc2af97dac9baa7ac8c68593ea9d8981cdff7fda4240647585a4de8061c
diff --git a/app-admin/puppet-agent/puppet-agent-1.5.1.ebuild b/app-admin/puppet-agent/puppet-agent-1.5.1.ebuild
new file mode 100644
index 000000000000..a60350d84b91
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.5.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}