summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-29 11:51:46 -0500
committerMatt Turner <mattst88@gentoo.org>2022-11-29 11:53:21 -0500
commitea0bb7cd3b47dd02d964a5c27c010eeaea8cc8b1 (patch)
tree2eca243d5724710dd899087b1a5a11fa8914abf5
parentnet-libs/gssdp: Drop old versions (diff)
downloadgentoo-ea0bb7cd.tar.gz
gentoo-ea0bb7cd.tar.bz2
gentoo-ea0bb7cd.zip
gnome-extra/zenity: Revbump to support webkit-gtk:4.1
Thanks to Vladislav Mikhailikov for the suggestion and the patch! Closes: https://bugs.gentoo.org/881643 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/zenity/files/zenity-3.42.1-webkit-gtk-4.1.patch12
-rw-r--r--gnome-extra/zenity/zenity-3.42.1-r1.ebuild60
2 files changed, 72 insertions, 0 deletions
diff --git a/gnome-extra/zenity/files/zenity-3.42.1-webkit-gtk-4.1.patch b/gnome-extra/zenity/files/zenity-3.42.1-webkit-gtk-4.1.patch
new file mode 100644
index 000000000000..ff7cbcb6b104
--- /dev/null
+++ b/gnome-extra/zenity/files/zenity-3.42.1-webkit-gtk-4.1.patch
@@ -0,0 +1,12 @@
+diff -Nurw a/meson.build b/meson.build
+--- a/meson.build 2022-04-27 04:33:34.670853100 +0300
++++ b/meson.build 2022-11-17 12:32:05.106347423 +0300
+@@ -70,7 +70,7 @@
+ endif
+ endif
+
+-webkitgtk = dependency('webkit2gtk-4.0', version: '>= 2.8.1', required: false)
++webkitgtk = dependency('webkit2gtk-4.1', version: '>= 2.8.1', required: false)
+ if get_option('webkitgtk')
+ if webkitgtk.found()
+ zenity_conf.set('HAVE_WEBKITGTK', true)
diff --git a/gnome-extra/zenity/zenity-3.42.1-r1.ebuild b/gnome-extra/zenity/zenity-3.42.1-r1.ebuild
new file mode 100644
index 000000000000..14be941b6398
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.42.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=x11-libs/gtk+-3.16.0:3[X]
+ >=dev-libs/glib-2.43.4:2
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4.1 )
+ x11-libs/libX11
+
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-webkit-gtk-4.1.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use libnotify)
+ $(meson_use webkit webkitgtk)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}