summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-04 01:39:37 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-04 02:50:05 -0500
commitea0f299441f24dc10a7506ea33a2d32356d1ece1 (patch)
tree4688e64eccf52103c0ea36c550a16d5a7e624854
parentx11-terms/kitty-shell-integration: initial import, version 0.24.0 (diff)
downloadgentoo-ea0f2994.tar.gz
gentoo-ea0f2994.tar.bz2
gentoo-ea0f2994.zip
x11-terms/kitty-shell-integration: add live ebuild
Needed by kitty-9999 and, similarly to terminfo, should preferably be kept in sync if updating kitty-9999 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild
new file mode 100644
index 000000000000..4bf3e29efd4b
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}