summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-01 20:27:33 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-01 21:29:37 +0100
commitea1f96da6f428d686b9e1b96f66548e2d52782e6 (patch)
tree8578f9fbafa177e528d6a200c7611439746fa00d
parentdev-dotnet/fantomas: rmove nuget.config files with find (diff)
downloadgentoo-ea1f96da6f428d686b9e1b96f66548e2d52782e6.tar.gz
gentoo-ea1f96da6f428d686b9e1b96f66548e2d52782e6.tar.bz2
gentoo-ea1f96da6f428d686b9e1b96f66548e2d52782e6.zip
dev-dotnet/netcoredbg: rmove nuget.config files with find
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-dotnet/netcoredbg/netcoredbg-3.0.0.1012.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-dotnet/netcoredbg/netcoredbg-3.0.0.1012.ebuild b/dev-dotnet/netcoredbg/netcoredbg-3.0.0.1012.ebuild
index a54b30a02cb2..9605178c2d4e 100644
--- a/dev-dotnet/netcoredbg/netcoredbg-3.0.0.1012.ebuild
+++ b/dev-dotnet/netcoredbg/netcoredbg-3.0.0.1012.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -198,11 +198,13 @@ src_prepare() {
fi
export DOTNET_CLI_TELEMETRY_OPTOUT=1
+ export DOTNET_NOLOGO=1
export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=1
export MSBUILDDISABLENODEREUSE=1
export UseSharedCompilation=false
- cat <<EOF > nuget.config || die
+ find "${S}" -type f -iname nuget.config -exec rm -v {} + || die
+ cat <<-EOF > NuGet.config || die
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<packageSources>
@@ -211,7 +213,7 @@ src_prepare() {
</packageSources>
</configuration>
EOF
- cp nuget.config tools/generrmsg/nuget.xml || die
+ cp NuGet.config tools/generrmsg/nuget.xml || die
cmake_src_prepare
}