summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2024-03-09 21:49:17 +0300
committerSam James <sam@gentoo.org>2024-03-09 20:53:38 +0000
commitea2b6a11aca27a11c87862518b9a536f8af94738 (patch)
tree7273c3fd15ee2b3b8c1159df8cb57bb0ffbde55d
parentdev-util/codeblocks: 20.03-r7, fix DoxyBlocks plugin startup segfault (diff)
downloadgentoo-ea2b6a11.tar.gz
gentoo-ea2b6a11.tar.bz2
gentoo-ea2b6a11.zip
dev-util/codeblocks: 20.03-r7, fix Scintilla buffer over-read warning
Upstream patch: https://sourceforge.net/u/vic5/scintilla/ci/6d0ce3 Upstream issue: https://sourceforge.net/p/scintilla/bugs/2019/ [sam: Revbump done in previous commit.] Bug: https://bugs.gentoo.org/925955 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/35687 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/codeblocks/codeblocks-20.03-r7.ebuild1
-rw-r--r--dev-util/codeblocks/files/codeblocks-20.03_Scintilla_fix_buffer_over-read_with_absolute_reference.patch24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-20.03-r7.ebuild b/dev-util/codeblocks/codeblocks-20.03-r7.ebuild
index a3c08cf9ffa1..96c7e10e1ae8 100644
--- a/dev-util/codeblocks/codeblocks-20.03-r7.ebuild
+++ b/dev-util/codeblocks/codeblocks-20.03-r7.ebuild
@@ -51,6 +51,7 @@ PATCHES=(
"${FILESDIR}"/${P}-env.patch
"${WORKDIR}"/patches/
"${FILESDIR}"/${P}_fix_DoxyBlocks_startup_segfault.patch
+ "${FILESDIR}"/${P}_Scintilla_fix_buffer_over-read_with_absolute_reference.patch
)
src_prepare() {
diff --git a/dev-util/codeblocks/files/codeblocks-20.03_Scintilla_fix_buffer_over-read_with_absolute_reference.patch b/dev-util/codeblocks/files/codeblocks-20.03_Scintilla_fix_buffer_over-read_with_absolute_reference.patch
new file mode 100644
index 000000000000..7ef01faf9cd2
--- /dev/null
+++ b/dev-util/codeblocks/files/codeblocks-20.03_Scintilla_fix_buffer_over-read_with_absolute_reference.patch
@@ -0,0 +1,24 @@
+Upstream patch: https://sourceforge.net/u/vic5/scintilla/ci/6d0ce3c92a1371372bd601cd572a078d5e4041a4/
+Upstream issue: https://sourceforge.net/p/scintilla/bugs/2019/
+Codeblocks forum discussion: https://forums.codeblocks.org/index.php?topic=24505.0
+
+lexers/LexMMIXAL.cxxDiffSwitch to side-by-side view
+--- a/src/sdk/wxscintilla/src/scintilla/lexers/LexMMIXAL.cxx
++++ b/src/sdk/wxscintilla/src/scintilla/lexers/LexMMIXAL.cxx
+@@ -99,12 +99,11 @@
+ }
+ } else if (sc.state == SCE_MMIXAL_REF) { // REF
+ if (!IsAWordChar(sc.ch) ) {
+- char s[100];
+- sc.GetCurrent(s, sizeof(s));
++ char s0[100];
++ sc.GetCurrent(s0, sizeof(s0));
++ const char *s = s0;
+ if (*s == ':') { // ignore base prefix for match
+- for (size_t i = 0; i != sizeof(s); ++i) {
+- *(s+i) = *(s+i+1);
+- }
++ ++s;
+ }
+ if (special_register.InList(s)) {
+ sc.ChangeState(SCE_MMIXAL_REGISTER);