summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-06-27 08:59:57 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-06-29 22:40:38 -0400
commitea3f59777a76bb44feeef346e9d55496a5826646 (patch)
tree27480b1b5d7cee26196eb787fa5bad630257f193
parentwww-client/qutebrowser: upgrade to 2.3.0 (diff)
downloadgentoo-ea3f5977.tar.gz
gentoo-ea3f5977.tar.bz2
gentoo-ea3f5977.zip
media-libs/glfw: Add support for multilib
This is required for proprietary games compiled only for x86_32. Closes: https://bugs.gentoo.org/580890 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/21441 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-libs/glfw/glfw-3.3.4-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/glfw/glfw-3.3.4-r1.ebuild b/media-libs/glfw/glfw-3.3.4-r1.ebuild
new file mode 100644
index 000000000000..43f33ee0dd73
--- /dev/null
+++ b/media-libs/glfw/glfw-3.3.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="https://www.glfw.org/"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+IUSE="wayland"
+
+RDEPEND="
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ !wayland? (
+ virtual/opengl[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXinerama[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
+ )
+ wayland? (
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ media-libs/mesa[egl,wayland,${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ !wayland? (
+ x11-base/xorg-proto
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ wayland? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLFW_BUILD_EXAMPLES=no
+ -DGLFW_USE_WAYLAND="$(usex wayland)"
+ -DBUILD_SHARED_LIBS=1
+ )
+ cmake-multilib_src_configure
+}