summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-28 16:50:30 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-28 16:54:59 -0400
commitea3f9189a5ac0b5c175fd54228aa7702e9e9c632 (patch)
tree8e38c4827e9b67347bf09af7971ce2558180ccde
parentnet-misc/pedro: fix typo in comment (diff)
downloadgentoo-ea3f9189a5ac0b5c175fd54228aa7702e9e9c632.tar.gz
gentoo-ea3f9189a5ac0b5c175fd54228aa7702e9e9c632.tar.bz2
gentoo-ea3f9189a5ac0b5c175fd54228aa7702e9e9c632.zip
games-kids/gmult: add 14.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-kids/gmult/Manifest1
-rw-r--r--games-kids/gmult/gmult-14.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/games-kids/gmult/Manifest b/games-kids/gmult/Manifest
index 536d5db037b0..be30cf12d9c4 100644
--- a/games-kids/gmult/Manifest
+++ b/games-kids/gmult/Manifest
@@ -1 +1,2 @@
DIST gmult-13.0.tar.bz2 202650 BLAKE2B 894a7a5fda188497e4c3a431f40b1ccff6ab875e2938b8d4174fa8d1925087b921eca989a7678d9c99c8afc242c5ad741de0b88947a094da40469b6c1f803ac0 SHA512 08c162c6a7184d38044fd11f1bb04b50dd0ab763c60150bb3b706faff8b4ea360fd44c53bd41422e164593a869416a366927f9b90c923b372cf1f25b61b424a1
+DIST gmult-14.0.tar.bz2 202720 BLAKE2B d9a3684eaef34ffbdba99f8d71c5166baea6535c134979f778b99a3c10a80b2f34f0b26f63328fd1e94dc0f2b15a8bf1cab1cf14a1f8f1ddab7dce79232e4424 SHA512 b08dc9d79d568ad7346f37acefd8351e6be17234a0e2477d3425dcba16bde2c96052598806ebd2328e9c16456b8b8c8c3e6df8100c90741fbbc0171d0c01486a
diff --git a/games-kids/gmult/gmult-14.0.ebuild b/games-kids/gmult/gmult-14.0.ebuild
new file mode 100644
index 000000000000..5e0f2317d381
--- /dev/null
+++ b/games-kids/gmult/gmult-14.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Multiplication Puzzle emulates the multiplication game found in Emacs"
+HOMEPAGE="https://gitlab.gnome.org/mterry/gmult/"
+SRC_URI="https://gitlab.gnome.org/mterry/gmult/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # only used for unnecessary .desktop/.po validation
+
+RDEPEND="
+ dev-libs/glib:2
+ >=gui-libs/gtk-4.14:4[introspection]
+ >=gui-libs/libadwaita-1.5:1[vala]
+ media-libs/graphene
+ virtual/libintl
+ x11-libs/cairo
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+"
+
+DOCS=( NEWS.md README.md )
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}