summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-05-02 16:25:20 +0200
committerAgostino Sarubbo <ago@gentoo.org>2024-05-02 16:25:20 +0200
commitea553f95262e4a430e20f807c7ab77c713c6102e (patch)
tree501a12e1fba8893005604d931738b0ab8fe927ee
parentapp-crypt/yubikey-manager: allow running against ~dev-python/keyring-25 (diff)
downloadgentoo-ea553f95262e4a430e20f807c7ab77c713c6102e.tar.gz
gentoo-ea553f95262e4a430e20f807c7ab77c713c6102e.tar.bz2
gentoo-ea553f95262e4a430e20f807c7ab77c713c6102e.zip
app-admin/exo: version bump to 1.77.2 - use go-module.eclass
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.77.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index ec87aec67339..e4406e8ca937 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.77.1.gh.tar.gz 11091028 BLAKE2B 0aa0f82cff7e3807bd5237fc9c8f77583eb98c8b10a6c49a529c19f95017e60a752478e093f072f5e7b52b2f9b7386a60786f40938d43f0cef996d77fa969c38 SHA512 815b82761947eaf39b8336eb7f24b5db16b8fb5904b4234cbf20d1b1cec058182079b04f5eca9020475b60f3c9e93410e58e2bf1eafa30f341b9962c542437e4
+DIST exo-1.77.2.gh.tar.gz 11091512 BLAKE2B 879dd3b8d6ce388efd52434dc5f26091360cb115c227dd47f5ece69ba3884b69715bdd2d503ce6145a7a368f19a19d822b16054f446fe70d7583041d494f14db SHA512 7ca505b5f1dc974baab13b5b0ff650aafc5261b2b601f17e35a9f37198ec4d6a9179163f67da360a56d50f1bf2d5d233ef5c1836143a5a306d336a93df95f249
diff --git a/app-admin/exo/exo-1.77.2.ebuild b/app-admin/exo/exo-1.77.2.ebuild
new file mode 100644
index 000000000000..867c5c8ff6e8
--- /dev/null
+++ b/app-admin/exo/exo-1.77.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND=">=dev-lang/go-1.16:="
+RESTRICT="strip"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ ego build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit="
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}