summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-10-03 23:12:44 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-10-03 23:13:52 +0200
commitea665954d9d21908f37214de2c59db6c6e337f35 (patch)
treea2a34fb2447f122db45e8a7b6a5ea597690fccc8
parentmedia-libs/libmad: Fix vulnerabilities, EAPI-7 bump (diff)
downloadgentoo-ea665954.tar.gz
gentoo-ea665954.tar.bz2
gentoo-ea665954.zip
dev-python/dominate: bump to 2.3.4
Signed-off-by: Louis Sautier <sbraz@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--dev-python/dominate/Manifest1
-rw-r--r--dev-python/dominate/dominate-2.3.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/dominate/Manifest b/dev-python/dominate/Manifest
index b6141b973430..afb073abe795 100644
--- a/dev-python/dominate/Manifest
+++ b/dev-python/dominate/Manifest
@@ -1,2 +1,3 @@
DIST dominate-2.2.1.zip 46460 BLAKE2B b09984978755f9020e78873aec73c09ccdf0113b99f1a0c9dcf43307a5523000f04ef2e063d03e636e2e958aa5dbd69993a8c606838cceb216599b314ab24a2e SHA512 3f79fa4258f98708b1e169693e83f919179c1148f440300426f907e28c26b28c21a1098793a14f7e89e5aba0de61f93c889a4908f0eb6e3641ffe234e215e597
DIST dominate-2.3.1.tar.gz 27887 BLAKE2B 3ac0820bd0cb79e648dc947d3cb69aa207e3c129cbae05daaca8fd3a6e22c67bd20fa350ce211986451caa7feb5b60c8ff692e568073e007c34de7cb8847b8a1 SHA512 599147cd9aabc7c3bc24e6c82a13b690808899107999a3b0d7d3f2f113b38c90f2c720298ffdcdf1933d2573cced05d730dab53265397b7fc010e57feabc10b3
+DIST dominate-2.3.4.tar.gz 27834 BLAKE2B 12eadd39e5088768c2cfc15e23093c53c58d90dab6346ac78d47da8b7d41fb50fabf4e186b9fea18ecb54fe8b6dae03a489b27a1942cfdc13437afe9e86919ef SHA512 6cab8d6d795498d70f28c80064407616e74e027ac112f8e097509482dce000e45c3599989430a17f71631616a860e84d842b2bfac39b4be466593b5cfb20123c
diff --git a/dev-python/dominate/dominate-2.3.4.ebuild b/dev-python/dominate/dominate-2.3.4.ebuild
new file mode 100644
index 000000000000..078ac80b939c
--- /dev/null
+++ b/dev-python/dominate/dominate-2.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}