summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:54:41 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:47 +0100
commitea743d2d95f80a1f543598b1f4b0d03a1e8cfcbf (patch)
tree498b6be02109fc10d29a564f3352d2d073a44c22
parentapp-misc/elasticsearch: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-ea743d2d95f80a1f543598b1f4b0d03a1e8cfcbf.tar.gz
gentoo-ea743d2d95f80a1f543598b1f4b0d03a1e8cfcbf.tar.bz2
gentoo-ea743d2d95f80a1f543598b1f4b0d03a1e8cfcbf.zip
app-misc/fhem: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/fhem/fhem-6.0-r1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-misc/fhem/fhem-6.0-r1.ebuild b/app-misc/fhem/fhem-6.0-r1.ebuild
index 9ad9768d8330..e85f6305a8f0 100644
--- a/app-misc/fhem/fhem-6.0-r1.ebuild
+++ b/app-misc/fhem/fhem-6.0-r1.ebuild
@@ -101,3 +101,7 @@ src_install() {
fowners fhem:fhem /opt/fhem/fhem.cfg
}
+
+pkg_postinst() {
+ tmpfiles_process fhem.conf
+}