summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-28 02:41:01 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-28 03:12:43 +0200
commitea8099c73ffdbdba8c8c5d22bb75405f1545a595 (patch)
tree1f202f8bd61ab579c105663d1aa1f0c44f989dde
parentdev-lang/typescript: drop old 4.9.5 (diff)
downloadgentoo-ea8099c73ffdbdba8c8c5d22bb75405f1545a595.tar.gz
gentoo-ea8099c73ffdbdba8c8c5d22bb75405f1545a595.tar.bz2
gentoo-ea8099c73ffdbdba8c8c5d22bb75405f1545a595.zip
dev-lang/typescript: bump to 5.1.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-5.1.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index 3bda0d48d08c..22061c9cc58d 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1,2 +1,3 @@
DIST typescript-5.0.4.tgz 7051452 BLAKE2B ed08425d8324a910f2d328fb02f27e08f75334fb190d1c4625452d076d615726d0e852da06f0f25146a4b02c6c99cd569bbcf7c50f5d6ff32c88a40101a59656 SHA512 716f53e56f71637edc73e8df127694bd7f757e8c6d1e4cdadcdc37c24a05e2c4a52a7d0c38d7647449dd8a0fea3c15973649a9961dcdcdac90cc2887338fe1ab
DIST typescript-5.1.3.tgz 7147721 BLAKE2B 5a18d18bcbe702c82a108624c189e6b03d72f74e16ccf6af2448c71c1decfcc7995b53524472e106c19ef01ec95df772ccfeed3e76fad1eb59f29bbe42668fb0 SHA512 5c7eb6ec4f6f91eaa1959150b8bf94b3201712789b4f491647615638d96be2c4e3bf1c89627c9e7e0ae4c8408bccce4d7a798acd1032dab47f3a560b0351e467
+DIST typescript-5.1.5.tgz 7147776 BLAKE2B 6aa416a68b17b30de0203a33bf9cd14ee519f50e860bd745a92d7571b3565b1c98d9369037dc4fcd19a5c9080085d67aea91bebd53c08ff757e1f4ed6b6e5320 SHA512 14e1fe58dfc342352f37a5a05be738325df28b43c7f9affcabe90d21f45e86fd702e158e35e770f398aefaf437f56a78f48cd3244b19da5c8b5e9045ee6905d6
diff --git a/dev-lang/typescript/typescript-5.1.5.ebuild b/dev-lang/typescript/typescript-5.1.5.ebuild
new file mode 100644
index 000000000000..598301d43b33
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}