summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-12 21:17:46 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-13 00:21:59 +0100
commitea997bf2b5d067b1414ee31611401a7df4d1c890 (patch)
tree2393b810fb2acb605c03d33f4301722dab37f5fe
parentdev-lang/boogie: disable the z3-hard-timeout test (diff)
downloadgentoo-ea997bf2b5d067b1414ee31611401a7df4d1c890.tar.gz
gentoo-ea997bf2b5d067b1414ee31611401a7df4d1c890.tar.bz2
gentoo-ea997bf2b5d067b1414ee31611401a7df4d1c890.zip
dev-lang/fuzion: drop old 0.084
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/fuzion/Manifest1
-rw-r--r--dev-lang/fuzion/fuzion-0.084.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-lang/fuzion/Manifest b/dev-lang/fuzion/Manifest
index aff32cd3c143..50c58d72012c 100644
--- a/dev-lang/fuzion/Manifest
+++ b/dev-lang/fuzion/Manifest
@@ -1,2 +1 @@
-DIST fuzion-0.084.tar.gz 858114 BLAKE2B 0c0f30b22a85527ae7acf2150e18c79257ac60cd5c17ec9d7e53a6f8e496f1dafa199dfdd34a0c4940dcdce28d1c8c794b1d5a5ff4fe3b3fa6229862be760027 SHA512 cb628557dcdb7835a77e1472e45da485e69706487aa26d74fc630272fcb5e408adcd7b1ed485e0c7b34eed761911b15126ac82ef0fd748354da02fda09b9dbe9
DIST fuzion-0.085.tar.gz 951247 BLAKE2B 5ae8999453759e0a8e5fb44b0aec833adb2c66ca9fea3e3092e2f298cc27a98c75abe0947337e9bb43920009d3bed8aa526a325fc58791d6177cb4f2d7ae7f23 SHA512 4a40eeffaa40b0568d90a20cf4125e7bddcc651fbe55b38866bb3cc90517749259336f776c33b762969986accae01e532b09418114b7c60e98377074bf144a17
diff --git a/dev-lang/fuzion/fuzion-0.084.ebuild b/dev-lang/fuzion/fuzion-0.084.ebuild
deleted file mode 100644
index 33cad58c2ef8..000000000000
--- a/dev-lang/fuzion/fuzion-0.084.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit java-pkg-2
-
-DESCRIPTION="A language with a focus on simplicity, safety and correctness"
-HOMEPAGE="https://flang.dev/
- https://github.com/tokiwa-software/fuzion/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/tokiwa-software/${PN}.git"
-else
- SRC_URI="https://github.com/tokiwa-software/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=virtual/jre-17:*
- dev-libs/boehm-gc
-"
-DEPEND="
- >=virtual/jdk-17:*
-"
-BDEPEND="
- test? ( sys-devel/clang:* )
-"
-
-DOCS=( README.md release_notes.md )
-
-src_compile() {
- emake -j1
-}
-
-src_test() {
- emake -j1 run_tests_parallel
-}
-
-src_install() {
- # Remove unnecessary files from build directory. bug #893450
- local torm
- local torm_path
- for torm in tests run_tests.{failures,results} ; do
- torm_path="${S}/build/${torm}"
-
- if [[ -e "${torm_path}" ]] ; then
- rm -r "${torm_path}" || die "failed to remove ${torm_path}"
- fi
- done
-
- insinto "/usr/share/${PN}"
- doins -r build/.
- insopts -m755
- doins -r build/bin
-
- local bin
- for bin in fz fzjava ; do
- dosym -r "/usr/share/${PN}/bin/${bin}" "/usr/bin/${bin}"
- done
-
- einstalldocs
-}