summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-10-08 22:06:42 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-09 12:01:51 +0200
commiteaa7a6fa3c2e601462c7c19f4e81257e3a58557b (patch)
tree4e525899d7849d4cd2e6887d5085f21de572d5d7
parentprofiles: arm: Unmask media-video/vlc[aribsub] (diff)
downloadgentoo-eaa7a6fa3c2e601462c7c19f4e81257e3a58557b.tar.gz
gentoo-eaa7a6fa3c2e601462c7c19f4e81257e3a58557b.tar.bz2
gentoo-eaa7a6fa3c2e601462c7c19f4e81257e3a58557b.zip
media-video/obs-studio: fix building without Python targets
Only call 'python-single-r1_pkg_setup' if USE="python" is set, since without supported Python targets, things will go bad even if USE="-python" is being used. Closes: https://bugs.gentoo.org/667896 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10109 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-video/obs-studio/obs-studio-21.1.2.ebuild6
-rw-r--r--media-video/obs-studio/obs-studio-22.0.3.ebuild6
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild6
3 files changed, 15 insertions, 3 deletions
diff --git a/media-video/obs-studio/obs-studio-21.1.2.ebuild b/media-video/obs-studio/obs-studio-21.1.2.ebuild
index bba5ad05ece0..ca9114ce291b 100644
--- a/media-video/obs-studio/obs-studio-21.1.2.ebuild
+++ b/media-video/obs-studio/obs-studio-21.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -69,6 +69,10 @@ PATCHES=(
CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_configure() {
local libdir=$(get_libdir)
local mycmakeargs=(
diff --git a/media-video/obs-studio/obs-studio-22.0.3.ebuild b/media-video/obs-studio/obs-studio-22.0.3.ebuild
index 987d58bb89bf..7bd98fa4213b 100644
--- a/media-video/obs-studio/obs-studio-22.0.3.ebuild
+++ b/media-video/obs-studio/obs-studio-22.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -66,6 +66,10 @@ PATCHES=( "${FILESDIR}/${PN}-21.1.2-use-less-automagic.patch" )
CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_configure() {
local libdir=$(get_libdir)
local mycmakeargs=(
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index d3014eda9ede..a596540a779f 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -64,6 +64,10 @@ RDEPEND="${COMMON_DEPEND}"
CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_configure() {
local libdir=$(get_libdir)
local mycmakeargs=(