summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-07-28 11:43:59 -0400
committerCraig Andrews <candrews@gentoo.org>2022-07-28 11:44:41 -0400
commiteaacd396efef44acc934be681c70bd23be52affd (patch)
tree447f6146df1990dfd47259608781ae4eaccd9630
parentnet-wireless/kismet: fix live build (diff)
downloadgentoo-eaacd396.tar.gz
gentoo-eaacd396.tar.bz2
gentoo-eaacd396.zip
net-p2p/cpuminer-opt: add 3.20.1
Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.20.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 8f9216b56ad2..89165883d0bc 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -2,3 +2,4 @@ DIST cpuminer-opt-3.16.4.tar.gz 1830534 BLAKE2B c9fa07c36b634b0d1250b847baa4a971
DIST cpuminer-opt-3.17.1.tar.gz 1840571 BLAKE2B db07547ec79df92f644e903485fb51abfddeafe2ecaffd18c0438cf292d51c6167eafaf7aa2b89cb6b7698d4358a4ef970459bff7b063cfd6d3a95ad878126eb SHA512 463d755bbb3146ef94292ae64a8a2397485e28b55d4b510881dd91461e3bcc2786a323cf575dd070481236b150c35af2898b5ab2b0db90c34f528821988af74c
DIST cpuminer-opt-3.18.0.tar.gz 1869910 BLAKE2B 23e090cb9c077fc69f6eee64a522676c078de268e512c588a7d93e1bd3e3904a9e5dbc937a58c21b031f685175b2f2164df04a4f7f22f8129d5183d1b990ec2f SHA512 9144a39b7470682835b57b5ff34810933af5712b4bb2e83a2b5241aeeb13747884f5f48e22e9a71512831b56d345ee5f0e6fd226a8a30d5d10243b4a99f1476c
DIST cpuminer-opt-3.19.8.tar.gz 1873570 BLAKE2B 9b20f47d5155ec3362172af93fab6a81b6a066c67a4c9c91ef95e9f4eddb5a325b62504414ae7b15d0088cbbda34e89741911ddd610ed727451d530d47ae141a SHA512 f8d172e906e379ddb635e64b0a626660a75aba2c1f74df014494ac934c7156664cdd2bef8963cd0433d20bca015228982b657b33be5c17bc3bd672867114a5eb
+DIST cpuminer-opt-3.20.1.tar.gz 1857399 BLAKE2B db41052f1020069b26839d12b5ac64c0dba352cb752faee1be86edfc2d21958d4ddc726d2c91c2fd1b9b5d5f08336592fd31e1a92fc37424f0d9137c082d8322 SHA512 98412c233749c87bb9629087c87350b559209f59e3ee7921b764dc0bb631b3a018368f33b4cde84d16725d67ac460f49d0aab0e838597e55f1ba47f8032cb4da
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.20.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.20.1.ebuild
new file mode 100644
index 000000000000..ae5b2d66fa4b
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.20.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}