summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-08 13:48:04 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-08 13:52:53 +0100
commiteacde6b9cc6969fd6be86ec647d80e3e771e5184 (patch)
tree0c9b840f6cc1473eaeba76af989e080f1265c0b2
parentdev-python/ubelt: enable py3.11 (diff)
downloadgentoo-eacde6b9cc6969fd6be86ec647d80e3e771e5184.tar.gz
gentoo-eacde6b9cc6969fd6be86ec647d80e3e771e5184.tar.bz2
gentoo-eacde6b9cc6969fd6be86ec647d80e3e771e5184.zip
dev-python/pychm: update EAPI 7 -> 8, pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/pychm/pychm-0.8.6-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pychm/pychm-0.8.6-r1.ebuild b/dev-python/pychm/pychm-0.8.6-r1.ebuild
new file mode 100644
index 000000000000..2f078383366b
--- /dev/null
+++ b/dev-python/pychm/pychm-0.8.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the chmlib library"
+HOMEPAGE="https://github.com/dottedmag/pychm"
+SRC_URI="https://github.com/dottedmag/pychm/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="dev-libs/chmlib"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # need to avoid relative import of 'chm' directory but tests rely
+ # on locating files relatively via tests/...
+ mv tests .. || die
+ cd .. || die
+ distutils-r1_src_test
+}