summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-06 20:29:30 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-06 20:30:27 +0200
commiteae906c69e90db43f8a25dc7c7050c0116f7a2f5 (patch)
tree0ccf6c86867eee93c962b85a0fb72dd027093d8a
parentsys-block/ndctl: Version bump to 72.1 (diff)
downloadgentoo-eae906c6.tar.gz
gentoo-eae906c6.tar.bz2
gentoo-eae906c6.zip
dev-python/pyzotero: add 1.5.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pyzotero/Manifest1
-rw-r--r--dev-python/pyzotero/pyzotero-1.5.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index 5fcc9c6a0857..d249ec7ddca0 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1,2 +1,3 @@
DIST pyzotero-1.4.26.tar.gz 520629 BLAKE2B 7ddcd55a1c21d6dcc4b610a9a29bc86ff002afdf2e2a90513219b9fd13b3d5b504736e122850fc81acf7a4bbca0b8c5da3a92c8eb3a6f07392e3d17a9dc7d73c SHA512 a0b0bf92458746b0dd0c01511efb05dd8fb471434c9e813c9d6dab7741a2eb1a10af2b9c5f68daa4c681353ba8c93cab140ec2da5962d06c76e8a229d4742009
+DIST pyzotero-1.5.1.gh.tar.gz 520410 BLAKE2B ac3aeb0f55f4685135bcf35594fc925f471a92ac9dfe866a4cffffc62d06b1447c80fedc566100d5fc9550ebcc54c7bcaa0b3d8494229791a4b51c806b40dc1c SHA512 76a498a6d16cef0024cd0e1a6d5011a4c2639a573746d0acd2d18616e452ad1f0eabbb92ae073e7e36ebc208870dedb2b3a01b0d70442b10ae81148e9b1cfd73
DIST pyzotero-1.5.gh.tar.gz 520234 BLAKE2B 0bb64710d7cb4701006884417b46d1fe6a76ae8bdcfbd3b30cc413c8cd3ab7ba024318a28cb8c49a1bf280bf3098ece3267a3580a4ecc55af48f47a436476d8b SHA512 9a2080e1e9886c8e4a2410dc7687637d844a2614d40e38403b408bf584f0b1e5d5a4e517bdcba2f4e0602e5a7a3f2a3c9195cfde20242cc9d1da2ca5d3aa8f4c
diff --git a/dev-python/pyzotero/pyzotero-1.5.1.ebuild b/dev-python/pyzotero/pyzotero-1.5.1.ebuild
new file mode 100644
index 000000000000..00400f165dfc
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="https://github.com/urschrei/pyzotero"
+SRC_URI="https://github.com/urschrei/pyzotero/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest