summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-30 01:25:58 +0100
committerSam James <sam@gentoo.org>2023-05-30 01:25:58 +0100
commiteaede904e6fe10bfa97f5a287395b654f452d6f1 (patch)
tree8931e8eb21656e9937b5fb067f29574598570363
parentdev-python/bracex: enable py3.12 (diff)
downloadgentoo-eaede904e6fe10bfa97f5a287395b654f452d6f1.tar.gz
gentoo-eaede904e6fe10bfa97f5a287395b654f452d6f1.tar.bz2
gentoo-eaede904e6fe10bfa97f5a287395b654f452d6f1.zip
app-portage/kuroneko: EAPI 8, PEP517, enable py3.12
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-portage/kuroneko/kuroneko-0.1.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-portage/kuroneko/kuroneko-0.1.3-r1.ebuild b/app-portage/kuroneko/kuroneko-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..5f1db112225d
--- /dev/null
+++ b/app-portage/kuroneko/kuroneko-0.1.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Vulnerability checker using data scraped from Gentoo Bugzilla"
+HOMEPAGE="https://github.com/projg2/kuroneko/"
+SRC_URI="
+ https://github.com/projg2/kuroneko/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="scraper"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ scraper? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest