summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-03 07:37:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-03 08:41:30 +0200
commiteaef3fae4e55473cd4fbd4fd3d0086624f0af50a (patch)
tree435771bd99bb34636d051841209f10adb074c2bd
parentdev-ruby/ffi: add 1.13.0 (diff)
downloadgentoo-eaef3fae.tar.gz
gentoo-eaef3fae.tar.bz2
gentoo-eaef3fae.zip
dev-python/iocapture: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/iocapture/iocapture-0.1.2-r2.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/dev-python/iocapture/iocapture-0.1.2-r2.ebuild b/dev-python/iocapture/iocapture-0.1.2-r2.ebuild
index 3b9cb84cb71f..216c2210675d 100644
--- a/dev-python/iocapture/iocapture-0.1.2-r2.ebuild
+++ b/dev-python/iocapture/iocapture-0.1.2-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
@@ -14,17 +14,10 @@ SRC_URI="https://github.com/oinume/iocapture/archive/${PV}.tar.gz -> ${P}.tar.gz
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc x86"
LICENSE="MIT"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- ${RDEPEND}
)"
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest