summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 07:56:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 07:58:27 +0200
commiteb03926764b273698c16e5ae6b15dc0ee2c88e84 (patch)
tree615d138e5dc4f108e913637c500fac1fe26cbaed
parentdev-python/peewee: Port to py3.9 (diff)
downloadgentoo-eb03926764b273698c16e5ae6b15dc0ee2c88e84.tar.gz
gentoo-eb03926764b273698c16e5ae6b15dc0ee2c88e84.tar.bz2
gentoo-eb03926764b273698c16e5ae6b15dc0ee2c88e84.zip
dev-python/pypng: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pypng/files/pypng-0.0.20-py39.patch34
-rw-r--r--dev-python/pypng/pypng-0.0.20.ebuild6
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/pypng/files/pypng-0.0.20-py39.patch b/dev-python/pypng/files/pypng-0.0.20-py39.patch
new file mode 100644
index 000000000000..e4c738ee3137
--- /dev/null
+++ b/dev-python/pypng/files/pypng-0.0.20-py39.patch
@@ -0,0 +1,34 @@
+From fe9c973c5e92f24746dfa1be8796c14a2befec4f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 15 Jul 2020 07:54:53 +0200
+Subject: [PATCH] test_png: Use array.tobytes to fix py3.9 compatibility
+
+The deprecated array.tostring() method has been removed in Python 3.9.
+Use .tobytes() instead.
+---
+ code/test_png.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/code/test_png.py b/code/test_png.py
+index c858d18..447c314 100644
+--- a/code/test_png.py
++++ b/code/test_png.py
+@@ -448,13 +448,13 @@ class Test(unittest.TestCase):
+ def test_interlaced_array(self):
+ """Reading an interlaced PNG yields each row as an array."""
+ r = png.Reader(bytes=pngsuite.basi0g08)
+- list(r.read()[2])[0].tostring
++ list(r.read()[2])[0].tobytes
+
+ def test_trns_array(self):
+ """A type 2 PNG with tRNS chunk yields each row
+ as an array (using asDirect)."""
+ r = png.Reader(bytes=pngsuite.tbrn2c08)
+- list(r.asDirect()[2])[0].tostring
++ list(r.asDirect()[2])[0].tobytes
+
+ def test_flat(self):
+ """Test read_flat."""
+--
+2.27.0
+
diff --git a/dev-python/pypng/pypng-0.0.20.ebuild b/dev-python/pypng/pypng-0.0.20.ebuild
index 9bb9cf785ed9..48293ee70a3f 100644
--- a/dev-python/pypng/pypng-0.0.20.ebuild
+++ b/dev-python/pypng/pypng-0.0.20.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -16,6 +16,10 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-py39.patch
+)
+
python_test() {
"${EPYTHON}" code/test_png.py -v || die "Tests fail with ${EPYTHON}"
}