summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-30 07:22:22 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-30 07:39:07 +0100
commiteb0af72c5d09d6b32d5b79d661f7747d14e21cc0 (patch)
tree22ac459bb179e19b194f8fe1b8e011261bc31c5f
parentdev-python/automat: Bump to 22.10.0 (diff)
downloadgentoo-eb0af72c5d09d6b32d5b79d661f7747d14e21cc0.tar.gz
gentoo-eb0af72c5d09d6b32d5b79d661f7747d14e21cc0.tar.bz2
gentoo-eb0af72c5d09d6b32d5b79d661f7747d14e21cc0.zip
dev-python/wsaccel: Bump to 0.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wsaccel/Manifest1
-rw-r--r--dev-python/wsaccel/wsaccel-0.6.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/wsaccel/Manifest b/dev-python/wsaccel/Manifest
index 701ce88fac1d..3ada886fa1e7 100644
--- a/dev-python/wsaccel/Manifest
+++ b/dev-python/wsaccel/Manifest
@@ -1 +1,2 @@
DIST wsaccel-0.6.3.tar.gz 9723 BLAKE2B 75da0f27e07b52ed730d239ef807da7ba9dd342144ca2e78c32dc09b20c1ebfc006aa9969b1f811d172ca18b75533a4560a29112e56d6dfd472117a0d072fc8e SHA512 0fe97c7fa94cec1b9cf019507f55ce633a9b4bda86329937cddcfa25ba94755010813688cda77ee4fea1c50918e45cd50770bb27e7583e630c46e84d27c155da
+DIST wsaccel-0.6.4.gh.tar.gz 9947 BLAKE2B 1c0b7b8b82154420f64fcbf3217938ff7e829573ada6b979ff73fe450c0985e368a47cccf2d124506c28479a98f0799977677e16ee26754611362f6b61eff902 SHA512 980364fab8a661c8a2b406f9eb6c99fb5f3a1308bbcf6267fa63f002d8dfbb4a3ad027d83a2088d69324cab05bdc56138d7e66e2602aeb8864dfe49ad9218d07
diff --git a/dev-python/wsaccel/wsaccel-0.6.4.ebuild b/dev-python/wsaccel/wsaccel-0.6.4.ebuild
new file mode 100644
index 000000000000..9ab10d76298f
--- /dev/null
+++ b/dev-python/wsaccel/wsaccel-0.6.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Accelerator for ws4py, autobahn and tornado"
+HOMEPAGE="
+ https://github.com/methane/wsaccel/
+ https://pypi.org/project/wsaccel/
+"
+SRC_URI="
+ https://github.com/methane/wsaccel/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd tests || die
+ epytest
+}