summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 17:40:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 18:17:02 +0200
commiteb10a52d2ec9172310a6ca3bc2b323c3bcfeb496 (patch)
tree6e860e699efba27986ee41fb9bfa56b491f95ae0
parentdev-python/h11: Enable py3.11 (diff)
downloadgentoo-eb10a52d2ec9172310a6ca3bc2b323c3bcfeb496.tar.gz
gentoo-eb10a52d2ec9172310a6ca3bc2b323c3bcfeb496.tar.bz2
gentoo-eb10a52d2ec9172310a6ca3bc2b323c3bcfeb496.zip
dev-python/hyperframe: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hyperframe/hyperframe-5.2.0-r1.ebuild23
-rw-r--r--dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild6
2 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/hyperframe/hyperframe-5.2.0-r1.ebuild b/dev-python/hyperframe/hyperframe-5.2.0-r1.ebuild
new file mode 100644
index 000000000000..682e8ea32ac7
--- /dev/null
+++ b/dev-python/hyperframe/hyperframe-5.2.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP/2 framing layer for Python"
+HOMEPAGE="
+ https://python-hyper.org/projects/hyperframe/en/latest/
+ https://pypi.org/project/hyperframe/
+ https://github.com/python-hyper/hyperframe/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
diff --git a/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild b/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild
index cddde028b09b..b86b597b3052 100644
--- a/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild
+++ b/dev-python/hyperframe/hyperframe-6.0.1-r1.ebuild
@@ -9,9 +9,11 @@ PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="HTTP/2 framing layer for Python"
-HOMEPAGE="https://python-hyper.org/projects/hyperframe/en/latest/
+HOMEPAGE="
+ https://python-hyper.org/projects/hyperframe/en/latest/
https://pypi.org/project/hyperframe/
- https://github.com/python-hyper/hyperframe/"
+ https://github.com/python-hyper/hyperframe/
+"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"