summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-17 09:26:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-17 15:10:53 +0200
commiteb11d4dae629517eeadc8483f20040943503d11a (patch)
tree65af403609cb3761f8599e3657ea1154e8b2f246
parentnet-mail/dovecot: cleanup (diff)
downloadgentoo-eb11d4dae629517eeadc8483f20040943503d11a.tar.gz
gentoo-eb11d4dae629517eeadc8483f20040943503d11a.tar.bz2
gentoo-eb11d4dae629517eeadc8483f20040943503d11a.zip
dev-python/aesara: Bump to 2.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aesara/Manifest1
-rw-r--r--dev-python/aesara/aesara-2.1.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index e86dd3ed15d6..dd98a73d4ee2 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,3 +1,4 @@
DIST aesara-rel-2.0.10.tar.gz 8038338 BLAKE2B 411623fe6299c9f037a733ff44324c747a3ea1bd71f2d3ca8fad747ec4be0d0dd9a3991f0996ee2e723ec9bb44ba9b47606e3a2cf5f9e6beb27bfa39752b1f1f SHA512 c29a352f2fe85cf5f452fcf7b62d2ccefcac37cfec5336a5b14041cfae5a25aa03f3c95e372453d665995576b6c73765c0b0677628f2ed37e63a390f8bfa5121
DIST aesara-rel-2.0.12.tar.gz 8154749 BLAKE2B 0e39102e985e9f9ed49f65c76389d76702b5d8fbe8c3e1130c61dce7c43eb70f5c73fd3557ff9aeaa1d186b33bb5803a04a4a5b0ce41076af7e923d05ce3353d SHA512 e68f5ce0c64a678219421a0bfc957d1594dc34c887af6f6373c00888387e5da83dec44b68b9309146ae2fd60c0677039980a87ee87ecc0ad3db2fbc80213cc34
DIST aesara-rel-2.1.0.tar.gz 8161534 BLAKE2B e17b70f7422f0f252cd6d248c16ebe2d609b77724d08251fed39d5f90de9dd36ca4006d767f3be8b0d0058f77f2d670033d058a24a5fa2df2c24ff5193e69c7d SHA512 d5e766eff03858fbf851e1baa0877b1cbc328408b3d2e760c2827ee662a0188e3b6dc5ceecb1c09d1f727171cf4c98c89b618f66695942558f44734a7405a88c
+DIST aesara-rel-2.1.1.tar.gz 8163328 BLAKE2B 5f2d05560f0c3cad0b58017f152011c9f10ebc8360ff925b90f6863fd2c683614cb42e86a69c53f0b168012fa1771ba37924afdf4f9600befad7d5af5a56f7ba SHA512 6a823201a7c4ca00a375dd7e1fcb38f31762e1eebe1079a1859b6ee709eb030c2d884364576b7925f5790c394f979bd5a738925c69c44c8e529757f435fb1a1e
diff --git a/dev-python/aesara/aesara-2.1.1.ebuild b/dev-python/aesara/aesara-2.1.1.ebuild
new file mode 100644
index 000000000000..efa88e842a94
--- /dev/null
+++ b/dev-python/aesara/aesara-2.1.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+MY_P=aesara-rel-${PV}
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="https://github.com/aesara-devs/aesara"
+SRC_URI="https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "s/tests.\*/tests\*/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local exclude=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+
+ # rounding problem?
+ # https://github.com/aesara-devs/aesara/issues/477
+ tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
+ tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
+ )
+
+ distutils_install_for_testing
+ # we do not package numba
+ epytest ${exclude[@]/#/--deselect } \
+ --ignore tests/link/test_numba.py \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
+python_install() {
+ rm "${BUILD_DIR}"/lib/bin/__init__.py || die
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}