summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-24 03:42:47 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-24 03:48:14 +0800
commiteb14c42c1b7ec25c01ae4f16cb095fdf9bec3043 (patch)
tree9496d504663fa80ebf2882bb27f9740df212db1e
parentsci-libs/tensorflow-estimator: bump 2.1 (diff)
downloadgentoo-eb14c42c1b7ec25c01ae4f16cb095fdf9bec3043.tar.gz
gentoo-eb14c42c1b7ec25c01ae4f16cb095fdf9bec3043.tar.bz2
gentoo-eb14c42c1b7ec25c01ae4f16cb095fdf9bec3043.zip
sci-visualization/tensorboard: bump 2.1.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
-rw-r--r--sci-visualization/tensorboard/Manifest1
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.1.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 0d4fa5cb8a94..a13b9fcc68d1 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,2 +1,3 @@
DIST tensorboard-1.15.0.zip 3765194 BLAKE2B 54a9987b65d4e2b127789f0e66eb5bdef8c024d19a82867632b44eefc4718bc6eb6c68fa61fdb2306af2c3adbacc3c75ec15f7aa331038b15cec27af2d846f85 SHA512 7b47d60929b4be91b4d56e36fc5a19b79511b8f3a1081fe308d3a107f978f2c5d23ad2d209104de983bc44f4506cdb0cb6e09b37e552dc042600ea16e14827dc
DIST tensorboard-2.0.0.zip 3776140 BLAKE2B 2bfd5b9d5b1c21f7df19ce5dae8a3d72381092630d1f53409fa0b96cab56be323ddef116bab95184d045f82fec88f4162e1f7277b25ed9c19b77189cf1a132ba SHA512 e87ea39eae9b64c3314de771de98c21148517aee4103a4bc23d674273b1a220248d6ba85a9f94481c6d67e8d3733af099b91df3dae38537411082c1595aad73d
+DIST tensorboard-2.1.0.zip 3835182 BLAKE2B c2c7dbc1ba4b85c52df6e693e1bd425bd76fe6db7ca25582b57d9c65c68b191dcdba2623ab0560139f1cac1bdf5c7a47261daaaf51fca46f2c5bf441f832a6fd SHA512 7463ace0863b90312a62a7fa96f4eca0147e85cf46ff21729f8996a794d54e14d876d3abe083d6aa4efd8e4e1582f7d5029de367f199981a34d4057b558bc51c
diff --git a/sci-visualization/tensorboard/tensorboard-2.1.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.1.0.ebuild
new file mode 100644
index 000000000000..c9b1f9175591
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit python-r1 python-utils-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ rm -rf "${S}/${PN}/_vendor/bleach" || die
+ rm -rf "${S}/${PN}/_vendor/html5lib" || die
+ sed -i -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import html5lib/import html5lib/' \
+ -e 's/^from tensorboard\._vendor import bleach/import bleach/' \
+ -e 's/^from tensorboard\._vendor\.html5lib/from html5lib/' \
+ -e 's/^from tensorboard\._vendor\.bleach/from bleach/' \
+ {} + || die "failed to unvendor"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}