summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-11-02 14:23:03 -0700
committerMatt Turner <mattst88@gentoo.org>2018-11-02 14:23:52 -0700
commiteb3fef9a8f43d4b973eaad8b162e8dcd3d992a3f (patch)
treed2eb9c6874db2ac62f292b970984a68987d30de9
parentdev-python/neovim-remote: take over as maintainer (diff)
downloadgentoo-eb3fef9a.tar.gz
gentoo-eb3fef9a.tar.bz2
gentoo-eb3fef9a.zip
media-libs/mesa: Add upstream patch to avoid build failure
Closes: https://bugs.gentoo.org/670094 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch34
-rw-r--r--media-libs/mesa/mesa-18.2.4.ebuild4
2 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch b/media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch
new file mode 100644
index 000000000000..11d4f9cac07d
--- /dev/null
+++ b/media-libs/mesa/files/mesa-18.2.4-meson-link-gallium-nine-with-pthreads.patch
@@ -0,0 +1,34 @@
+From 7652931d33b36c93b2e84713baa8c283d568402e Mon Sep 17 00:00:00 2001
+From: Dylan Baker <dylan@pnwbakers.com>
+Date: Thu, 1 Nov 2018 14:12:57 -0700
+Subject: [PATCH] meson: link gallium nine with pthreads
+
+In some cases (not building with llvm, which automatically pulls in
+pthreads) nine needs to be directly linked with pthreads. Fixes building
+on x86 (32 bit) without llvm.
+
+Distro bug: https://bugs.gentoo.org/670094
+Fixes: 6b4c7047d57178d3362a710ad503057c6a582ca3
+ ("meson: build gallium nine state_tracker")
+Tested-by: Rafal Lalik <rafallalik@gmail.com>
+Reviewed-by: Matt Turner <mattst88@gmail.com>
+---
+ src/gallium/targets/d3dadapter9/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gallium/targets/d3dadapter9/meson.build b/src/gallium/targets/d3dadapter9/meson.build
+index bd05b4f9692..bc72b1110a0 100644
+--- a/src/gallium/targets/d3dadapter9/meson.build
++++ b/src/gallium/targets/d3dadapter9/meson.build
+@@ -53,7 +53,7 @@ libgallium_nine = shared_library(
+ libswkmsdri,
+ ],
+ dependencies : [
+- dep_selinux, dep_expat, dep_libdrm, dep_llvm,
++ dep_selinux, dep_expat, dep_libdrm, dep_llvm, dep_thread,
+ driver_swrast, driver_r300, driver_r600, driver_radeonsi, driver_nouveau,
+ driver_i915, driver_svga,
+ ],
+--
+2.16.4
+
diff --git a/media-libs/mesa/mesa-18.2.4.ebuild b/media-libs/mesa/mesa-18.2.4.ebuild
index 2b4e1542fc5f..16b4ad7ea3b8 100644
--- a/media-libs/mesa/mesa-18.2.4.ebuild
+++ b/media-libs/mesa/mesa-18.2.4.ebuild
@@ -231,6 +231,10 @@ x86? (
)
)"
+PATCHES=(
+ "${FILESDIR}"/${P}-meson-link-gallium-nine-with-pthreads.patch
+)
+
llvm_check_deps() {
local flags=${MULTILIB_USEDEP}
if use video_cards_r600 || use video_cards_radeon || use video_cards_radeonsi