summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-11-06 08:38:28 +0000
committerMatthew Smith <matthew@gentoo.org>2022-11-06 08:52:30 +0000
commiteb435debc5ba2d294997b8f7fa583f3232ca2a72 (patch)
tree46b96a43bfc2caca349b2ed7395eb5c07a0ede3f
parentsci-electronics/kicad: add 6.0.9 (diff)
downloadgentoo-eb435deb.tar.gz
gentoo-eb435deb.tar.bz2
gentoo-eb435deb.zip
sci-electronics/kicad-footprints: add 6.0.9
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--sci-electronics/kicad-footprints/Manifest1
-rw-r--r--sci-electronics/kicad-footprints/kicad-footprints-6.0.9.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-electronics/kicad-footprints/Manifest b/sci-electronics/kicad-footprints/Manifest
index 1b3e91f0e3fe..e30018f443dd 100644
--- a/sci-electronics/kicad-footprints/Manifest
+++ b/sci-electronics/kicad-footprints/Manifest
@@ -2,3 +2,4 @@ DIST kicad-footprints-5.1.12.tar.bz2 3382783 BLAKE2B 6f7725bebd6099d86780ed2582a
DIST kicad-footprints-6.0.6.tar.gz 31647789 BLAKE2B 3af7027987b25c4a3ee19925acaa539cea643656e1662f0b80ec76c807aca9ef7433228fc88cdd0c34b80e7bbb886abd5c11765983e9adc5b347ce01bd4b51c4 SHA512 6d93a90bfc0b246c70b336aa9265a051a33d8b490a81271fb85ab73cd19184a031f3429ce8ae9e1650ece475a30f0f283c43c5bb2d1f427b4129d4ed61480ac0
DIST kicad-footprints-6.0.7.tar.gz 31657956 BLAKE2B 127ac81c83841919903b300af89c2126e1f53ff1c03d6dcd2466eac8d4733da4f923831e24aa43fca2b5c6d9ee4389bd67f0bd2b4d300adb5356e261b14e897e SHA512 e0959846e057df46e38385d1fe71895930435fc51ad03bbc893481264d969d9739967b069855b59341388fec5458a4f2c71c527b7af7357437c5606c91f5436d
DIST kicad-footprints-6.0.8.tar.gz 31697942 BLAKE2B f70d818b766ab2175ce638ced1d632b575b59c28167de037048ea49175448920a69458067c3cfe3237cc58ba08157a6fc7ffb34b96d17d64f32dd9bda5dc19e0 SHA512 e839e0b75657c76473cf6455f6c6c32ecd03d049e86ebb4abbf80e02de56e132fa0d32fc2b9e730d24dbd6cf770791589f9a0d8c2341cc8597705bf33edd4687
+DIST kicad-footprints-6.0.9.tar.gz 31723499 BLAKE2B 33856d28a52f8f516c96c38c68aabe3d57c3f7eade5cb654cd0dca15f36263b9860f252468edf0b94f228c2497ef7e862cebfd023e2a166ce1696a89c1cff1e1 SHA512 43436a61fb1be66dc6cd6079e49e7af0f7d374f074874fd008eb45c2b3faee596e102173a274064a536f11c4525f223c9e8c2a33969811414811a226e69affaa
diff --git a/sci-electronics/kicad-footprints/kicad-footprints-6.0.9.ebuild b/sci-electronics/kicad-footprints/kicad-footprints-6.0.9.ebuild
new file mode 100644
index 000000000000..e1268b9afd0d
--- /dev/null
+++ b/sci-electronics/kicad-footprints/kicad-footprints-6.0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools footprint libraries"
+HOMEPAGE="https://gitlab.com/kicad/libraries/kicad-footprints"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/kicad-footprints.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${MY_PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ fi
+
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sci-electronics/kicad-6.0.0"
+
+if [[ ${PV} == 9999 ]] ; then
+# x11-misc-util/macros only required on live ebuilds
+ BDEPEND+=" >=x11-misc/util-macros-1.18"
+fi