summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-10-16 11:08:15 +0100
committerIonen Wolkens <ionen@gentoo.org>2021-10-16 17:26:44 -0400
commiteb494cdc0dba010a65cfb21a7c4d8877ca25facc (patch)
treed596667e468a327338395464c82a039927b1b628
parentdev-cpp/asio: drop old (diff)
downloadgentoo-eb494cdc.tar.gz
gentoo-eb494cdc.tar.bz2
gentoo-eb494cdc.zip
dev-cpp/asio: version 1.20.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/22601 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.20.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index f75d42fe58fe..ccdb995c096d 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,2 +1,3 @@
DIST asio-1.10.8.tar.bz2 1270332 BLAKE2B 97e4a6a7c8b4562f10af1d122e9b08c12d567fd0447d1951a907f47f77832dcd42df4cb9b5b392feaaa2ea7c79d8bedfcf12e3052957ec012d8bb6b4d1347eb5 SHA512 d870686d2b19bec9925c311f2f0fd370e9797bbad252176a80a998f9c322ecd502b5081826105712e7caf87c03c3e6b70a0e219019e5bff46077d6e8c3c6db09
DIST asio-1.19.2.tar.bz2 1842597 BLAKE2B b2236c33432984ab660eba4c93be32374bb49f688a1e6a0711d7bac322cc4a7f817db209278f216468c6a72b9d3dd564cf298e1f49f8098c3fd9aec7acd66eb7 SHA512 07f9c29d8f02090b4d4b6a1867bcc07a8e9f3388556dff787ca3ba143022eeb63bfac0b5bc264076fed4db3b2e5ec6b7ff0ebefde40ba4753c832032a72d54cc
+DIST asio-1.20.0.tar.bz2 1845826 BLAKE2B a768dc0b9ae380bef07d674507f7571d0bc47e182cdde10b24cee246814874dd7739c523b071dfede61a12059f52e04d7bbd309a03d93070bc1dd4640c253c19 SHA512 6421960abd2cf0c205cc50e86adfe492bca2870b486328b4825dc0cefc9c40cdc085516d474c23e15a73f4c108c0e69add5fab6dbe594a1e53636c5c3027e4c5
diff --git a/dev-cpp/asio/asio-1.20.0.ebuild b/dev-cpp/asio/asio-1.20.0.ebuild
new file mode 100644
index 000000000000..0b91e779c0be
--- /dev/null
+++ b/dev-cpp/asio/asio-1.20.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/boost
+ dev-libs/openssl
+ )
+"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}