summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2017-06-07 17:31:16 -0400
committerJustin Bronder <jsbronder@gentoo.org>2017-06-07 17:56:10 -0400
commiteb697a36540a1c28319b96b92bf165cc003d53f4 (patch)
treed7316d7ac010717699a3ea51a2944af327616200
parentkde-plasma/plasma-meta: Add kde-plasma/plymouth-kcm (diff)
downloadgentoo-eb697a36540a1c28319b96b92bf165cc003d53f4.tar.gz
gentoo-eb697a36540a1c28319b96b92bf165cc003d53f4.tar.bz2
gentoo-eb697a36540a1c28319b96b92bf165cc003d53f4.zip
dev-python/sabyenc: initial import
Replacment of dev-python/yenc for net-nntp/sabnzbd. Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--dev-python/sabyenc/Manifest1
-rw-r--r--dev-python/sabyenc/files/0001-remove-hardcoded-cflags.patch25
-rw-r--r--dev-python/sabyenc/metadata.xml7
-rw-r--r--dev-python/sabyenc/sabyenc-3.0.2.ebuild25
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/sabyenc/Manifest b/dev-python/sabyenc/Manifest
new file mode 100644
index 000000000000..38bcbe670d82
--- /dev/null
+++ b/dev-python/sabyenc/Manifest
@@ -0,0 +1 @@
+DIST sabyenc-3.0.2.tar.gz 16081020 SHA256 fd49ebf56a391dca0cd5b42c185329218e21e9fb53130cab7111f7e3fed98a42 SHA512 70890421e87f9829b1ceacc11b7d1059f29e7fb1f33470b50088b38e05ce4d2433c9fda40532a4308bfbc1f01f1bde1670fa993ab7601b81133049a1b45798d5 WHIRLPOOL 4e2ed0dbe5ad14d940f556d2b66714c5e2e7db501a0b41189d5115ecd87357130d07796a9f1f74dc86d026061c2e5190e7564f0ca94f7b2ec16b87e5ffd53cc5
diff --git a/dev-python/sabyenc/files/0001-remove-hardcoded-cflags.patch b/dev-python/sabyenc/files/0001-remove-hardcoded-cflags.patch
new file mode 100644
index 000000000000..8ec43317f449
--- /dev/null
+++ b/dev-python/sabyenc/files/0001-remove-hardcoded-cflags.patch
@@ -0,0 +1,25 @@
+From 3f70d3f955048e31ccac668caa59199d8cb71b50 Mon Sep 17 00:00:00 2001
+From: Justin Bronder <jsbronder@gmail.com>
+Date: Wed, 7 Jun 2017 17:23:37 -0400
+Subject: [PATCH] remove hardcoded cflags
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index d198eac..e2d8f1a 100644
+--- a/setup.py
++++ b/setup.py
+@@ -32,7 +32,7 @@ setup(
+ url = "https://github.com/sabnzbd/sabnzbd-yenc",
+ license = "LGPLv3",
+ package_dir = {'sabyenc': 'src'},
+- ext_modules = [Extension("sabyenc", ["src/sabyenc.c"], extra_compile_args=["-O2"])],
++ ext_modules = [Extension("sabyenc", ["src/sabyenc.c"])],
+ classifiers = [
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.7",
+--
+2.10.2
+
diff --git a/dev-python/sabyenc/metadata.xml b/dev-python/sabyenc/metadata.xml
new file mode 100644
index 000000000000..664b1a9c9e03
--- /dev/null
+++ b/dev-python/sabyenc/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jsbronder@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/sabyenc/sabyenc-3.0.2.ebuild b/dev-python/sabyenc/sabyenc-3.0.2.ebuild
new file mode 100644
index 000000000000..bb1f9b3cee10
--- /dev/null
+++ b/dev-python/sabyenc/sabyenc-3.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: f817d96e09d5ad0b706abaadace1af19614d1acd $
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="https://github.com/sabnzbd/sabyenc/"
+SRC_URI="https://github.com/sabnzbd/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Remove forced CFLAG on setup.py
+PATCHES=( "${FILESDIR}"/0001-remove-hardcoded-cflags.patch )
+DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
+
+python_test() {
+ "${PYTHON}" test/test.py || die "Test failed."
+}