summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2019-10-18 08:59:13 +0200
committerRobin H. Johnson <robbat2@gentoo.org>2019-11-01 21:43:06 -0700
commiteb69fc34f003b38035037daf7f9e322110fb2769 (patch)
treeae15fbdb66fe0c9fdbf6842ab9a8c2b409412e24
parentnet-mail/checkpassword: use https (diff)
downloadgentoo-eb69fc34.tar.gz
gentoo-eb69fc34.tar.bz2
gentoo-eb69fc34.zip
net-mail/checkpassword: bump to EAPI7
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> (cherry picked from commit d538de140833170bf5da393ae38b136a6c924c65) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13332
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r4.ebuild38
-rw-r--r--net-mail/checkpassword/files/checkpassword-0.90-errno.patch (renamed from net-mail/checkpassword/files/0.90-errno.patch)4
-rw-r--r--net-mail/checkpassword/files/checkpassword-0.90-exit.patch (renamed from net-mail/checkpassword/files/0.90-exit.patch)0
-rw-r--r--net-mail/checkpassword/files/checkpassword-0.90-headers.patch98
4 files changed, 138 insertions, 2 deletions
diff --git a/net-mail/checkpassword/checkpassword-0.90-r4.ebuild b/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
new file mode 100644
index 000000000000..5029a6bdbeeb
--- /dev/null
+++ b/net-mail/checkpassword/checkpassword-0.90-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fixheadtails toolchain-funcs
+
+DESCRIPTION="A uniform password checking interface for root applications"
+HOMEPAGE="https://cr.yp.to/checkpwd.html"
+SRC_URI="https://cr.yp.to/checkpwd/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+RESTRICT="mirror bindist"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-errno.patch
+ "${FILESDIR}"/${P}-exit.patch
+ "${FILESDIR}"/${P}-headers.diff
+)
+
+src_prepare() {
+ default
+
+ ht_fix_file Makefile print-cc.sh
+
+ use static && append-ldflags -static
+
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS}" > ./conf-cc || die 'Patching conf-cc failed.'
+ echo "$(tc-getCC) ${LDFLAGS}" > ./conf-ld || die 'Patching conf-ld failed.'
+}
+
+src_install() {
+ dobin checkpassword
+ einstalldocs
+}
diff --git a/net-mail/checkpassword/files/0.90-errno.patch b/net-mail/checkpassword/files/checkpassword-0.90-errno.patch
index 9cf40c689c1e..0e152b4aee76 100644
--- a/net-mail/checkpassword/files/0.90-errno.patch
+++ b/net-mail/checkpassword/files/checkpassword-0.90-errno.patch
@@ -1,5 +1,5 @@
---- error.h.orig 2003-03-05 15:48:54.000000000 -0500
-+++ error.h 2003-03-05 15:49:08.000000000 -0500
+--- a/error.h 2003-03-05 15:48:54.000000000 -0500
++++ b/error.h 2003-03-05 15:49:08.000000000 -0500
@@ -1,7 +1,7 @@
#ifndef ERROR_H
#define ERROR_H
diff --git a/net-mail/checkpassword/files/0.90-exit.patch b/net-mail/checkpassword/files/checkpassword-0.90-exit.patch
index e8e4d2d1fc1e..e8e4d2d1fc1e 100644
--- a/net-mail/checkpassword/files/0.90-exit.patch
+++ b/net-mail/checkpassword/files/checkpassword-0.90-exit.patch
diff --git a/net-mail/checkpassword/files/checkpassword-0.90-headers.patch b/net-mail/checkpassword/files/checkpassword-0.90-headers.patch
new file mode 100644
index 000000000000..4644542204ba
--- /dev/null
+++ b/net-mail/checkpassword/files/checkpassword-0.90-headers.patch
@@ -0,0 +1,98 @@
+diff -aurp checkpassword-0.90-orig/alloc.c checkpassword-0.90/alloc.c
+--- checkpassword-0.90-orig/alloc.c 2019-10-18 18:32:45.888000000 +0200
++++ checkpassword-0.90/alloc.c 2019-10-18 18:39:41.820000000 +0200
+@@ -1,7 +1,6 @@
++#include <stdlib.h>
+ #include "alloc.h"
+ #include "error.h"
+-extern char *malloc();
+-extern void free();
+
+ #define ALIGNMENT 16 /* XXX: assuming that this alignment is enough */
+ #define SPACE 2048 /* must be multiple of ALIGNMENT */
+diff -aurp checkpassword-0.90-orig/checkpassword.c checkpassword-0.90/checkpassword.c
+--- checkpassword-0.90-orig/checkpassword.c 2019-10-18 18:32:45.888000000 +0200
++++ checkpassword-0.90/checkpassword.c 2019-10-18 18:42:00.352000000 +0200
+@@ -1,3 +1,4 @@
++#include <string.h>
+ #include <unistd.h>
+
+ #include "error.h"
+@@ -23,6 +24,7 @@ static struct userpw *upw;
+ static char up[513];
+ static int uplen;
+
++int
+ main(int argc,char **argv)
+ {
+ char *login;
+diff -aurp checkpassword-0.90-orig/chkshsgr.c checkpassword-0.90/chkshsgr.c
+--- checkpassword-0.90-orig/chkshsgr.c 2019-10-18 18:32:45.888000000 +0200
++++ checkpassword-0.90/chkshsgr.c 2019-10-18 18:38:29.436000000 +0200
+@@ -1,5 +1,8 @@
++#include <grp.h>
++#include <unistd.h>
+ #include "exit.h"
+
++int
+ main()
+ {
+ short x[4];
+diff -aurp checkpassword-0.90-orig/install.c checkpassword-0.90/install.c
+--- checkpassword-0.90-orig/install.c 2019-10-18 18:32:45.888000000 +0200
++++ checkpassword-0.90/install.c 2019-10-18 18:43:52.968000000 +0200
+@@ -1,3 +1,6 @@
++#include <sys/stat.h>
++#include <sys/types.h>
++#include <unistd.h>
+ #include "buffer.h"
+ #include "strerr.h"
+ #include "error.h"
+@@ -137,6 +140,7 @@ int mode;
+ strerr_die6sys(111,FATAL,"unable to chmod .../",subdir,"/",file,": ");
+ }
+
++int
+ main()
+ {
+ fdsourcedir = open_read(".");
+diff -aurp checkpassword-0.90-orig/instcheck.c checkpassword-0.90/instcheck.c
+--- checkpassword-0.90-orig/instcheck.c 2019-10-18 18:32:45.888000000 +0200
++++ checkpassword-0.90/instcheck.c 2019-10-18 18:42:42.428000000 +0200
+@@ -101,6 +101,7 @@ int mode;
+ perm("",home,"/",file,S_IFREG,uid,gid,mode);
+ }
+
++int
+ main()
+ {
+ hier();
+diff -aurp checkpassword-0.90-orig/pathexec_run.c checkpassword-0.90/pathexec_run.c
+--- checkpassword-0.90-orig/pathexec_run.c 2019-10-18 18:32:45.888000000 +0200
++++ checkpassword-0.90/pathexec_run.c 2019-10-18 18:40:42.944000000 +0200
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include "error.h"
+ #include "stralloc.h"
+ #include "str.h"
+diff -aurp checkpassword-0.90-orig/prot.c checkpassword-0.90/prot.c
+--- checkpassword-0.90-orig/prot.c 2019-10-18 18:32:45.888000000 +0200
++++ checkpassword-0.90/prot.c 2019-10-18 18:37:28.668000000 +0200
+@@ -1,3 +1,5 @@
++#include <grp.h>
++#include <unistd.h>
+ #include "hasshsgr.h"
+ #include "prot.h"
+
+diff -aurp checkpassword-0.90-orig/readwrite.h checkpassword-0.90/readwrite.h
+--- checkpassword-0.90-orig/readwrite.h 2019-10-18 18:32:45.888000000 +0200
++++ checkpassword-0.90/readwrite.h 2019-10-18 18:33:59.732000000 +0200
+@@ -1,7 +1,6 @@
+ #ifndef READWRITE_H
+ #define READWRITE_H
+
+-extern int read();
+-extern int write();
++#include <unistd.h>
+
+ #endif