summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-10 13:54:59 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-10 13:54:59 +0200
commiteb9211408a13f3f7fcc0aca0331836fbfdea093c (patch)
tree58c43ad48c8b0076b2beca94ffc88e25a619d70f
parentsys-cluster/kube-apiserver: Version bump to 1.7.5 (diff)
downloadgentoo-eb921140.tar.gz
gentoo-eb921140.tar.bz2
gentoo-eb921140.zip
net-analyzer/prometheus: Version bump to 2.0.0_beta2
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--net-analyzer/prometheus/Manifest1
-rw-r--r--net-analyzer/prometheus/prometheus-2.0.0_beta2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index bc51214ced27..0e93936ba007 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1,2 +1,3 @@
DIST prometheus-1.7.1.tar.gz 5122747 SHA256 209832310f5bef99faef3beaaa95263612a4d0126ca512c4a4c23a8543d3ccf5 SHA512 98a42e95978477530082d7549c29f17b133043d7c233ba3c90b183f06a3f24ee578f8fed75cba476d3c93a22abcccfdbccc94488beb8450a02f260d24165ba26 WHIRLPOOL 8ab473430752336e09b4a0c38fd1117abe21196478d7f2f7e813c27f07c950cc3525d9e9ba32309711c73a1032f3cff27ddc1582d0c4b6c66fe82d5b58675550
DIST prometheus-2.0.0_beta1.tar.gz 5521455 SHA256 25eee3f884ddb577f308d174c8eaf31718602afcffc1aef4c574fa9fe54687e6 SHA512 12b2e0ea0279526fd87c915b8ca2bdc2f29bd6041a7c6ad66bc3a7832e914275ba9bfa9d48db54e86dde3c0c1d347a7051fa92fcf33cfebe5b03f200845ef0d1 WHIRLPOOL ba5ff82e8b578c4b94ca539075c834138d2f2af6bea50c45861ea9ff3e592e4cbb32bb3e1ef9c0a3e9ff4e27c4e3025c22b3feb5cc93c33cbd6b8a17803da465
+DIST prometheus-2.0.0_beta2.tar.gz 5521490 SHA256 d8d54562209ff33f9a831e4de7ac0bc94dc743f9ed78d413437750c338d369a2 SHA512 27366ee07428a70cf142036dee4b7f9e24d135d017f6423ffb2fbea648d0601c2e14e927e1bccef5da7e2a2be9b47963e18d02d2759375a05a8b332a0733c1c5 WHIRLPOOL 860fa895ccfc60b08bb76510be4d15272e8b453a46f3af60c4c012e6319c9172762ae27b9bbf6192d73d81d402fd49f3b8b6869f5fc2a496c49345c204207c56
diff --git a/net-analyzer/prometheus/prometheus-2.0.0_beta2.ebuild b/net-analyzer/prometheus/prometheus-2.0.0_beta2.ebuild
new file mode 100644
index 000000000000..f990ccfe59b6
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-2.0.0_beta2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_beta/-beta.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="a52f082"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-2.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_beta1'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "It's generally advised to start with a clean storage directory"
+ fi
+}