summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-07 15:28:58 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-07 15:30:13 +0100
commiteb995ace8e1a1e3dc198a45fb8e01f3c12905f27 (patch)
tree9bbe2e7c17d79bc862e947b0fd4f7108814e48e9
parentsys-libs/libsmbios: fix Python shebangs where necessary (diff)
downloadgentoo-eb995ace.tar.gz
gentoo-eb995ace.tar.bz2
gentoo-eb995ace.zip
sys-libs/libsmbios: prune insecure RPATH from smbios-sys-info-lite
Closes: https://bugs.gentoo.org/380105 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.4.3-insecure_rpaths.patch13
-rw-r--r--sys-libs/libsmbios/libsmbios-2.4.3.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/sys-libs/libsmbios/files/libsmbios-2.4.3-insecure_rpaths.patch b/sys-libs/libsmbios/files/libsmbios-2.4.3-insecure_rpaths.patch
new file mode 100644
index 000000000000..e1390cb64770
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-2.4.3-insecure_rpaths.patch
@@ -0,0 +1,13 @@
+Instead of producing a static binary, this causes libtool to inject one
+of the build directories into RPATH.
+
+--- a/src/bin/Makefile.am
++++ b/src/bin/Makefile.am
+@@ -65,7 +65,6 @@
+ sbin_PROGRAMS += out/smbios-sys-info-lite
+ out_smbios_sys_info_lite_SOURCES = src/bin/smbios-sys-info-lite.c
+ out_smbios_sys_info_lite_LDADD = out/libsmbios_c.la out/libgetopt.la $(AM_LDADD)
+-out_smbios_sys_info_lite_LDFLAGS = $(AM_LDFLAGS) -static
+
+ sbin_PROGRAMS += out/smbios-get-ut-data
+ out_smbios_get_ut_data_SOURCES = src/bin/smbios-get-ut-data.c
diff --git a/sys-libs/libsmbios/libsmbios-2.4.3.ebuild b/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
index 1bec5f76a965..1a480d6268b6 100644
--- a/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
+++ b/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
@@ -32,6 +32,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-2.2.28-cppunit-tests.patch"
"${FILESDIR}/${PN}-2.4.3-avoid_bashisms.patch" #715202
+ "${FILESDIR}/${PN}-2.4.3-insecure_rpaths.patch"
)
pkg_setup() {