summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-21 14:35:20 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-21 14:46:21 +0100
commiteb9d5c9a323d0cd522338253a317305d5c99d6a8 (patch)
tree7f99739bcd4f552e9856749e2356c07fd98734d5
parentapp-admin/ansible-molecule: stabilize 5.1.0 for ALLARCHES (diff)
downloadgentoo-eb9d5c9a323d0cd522338253a317305d5c99d6a8.tar.gz
gentoo-eb9d5c9a323d0cd522338253a317305d5c99d6a8.tar.bz2
gentoo-eb9d5c9a323d0cd522338253a317305d5c99d6a8.zip
app-admin/ansible-molecule: drop 4.0.4
Closes: https://bugs.gentoo.org/905911 Closes: https://bugs.gentoo.org/908821 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-admin/ansible-molecule/Manifest1
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index e0f7659eb081..b850ee05029c 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,2 +1 @@
-DIST molecule-4.0.4.tar.gz 337260 BLAKE2B 14c493fa8aaa15466ebca19af9e5325ddb824c151d07d800136dcb714a430ea2dc42b38c9ec6e805e29ec3226376a532793d51c5d0544d6d5105510e5365ca8c SHA512 d7c1ceefbf74cbc27a397e7a40d855b23325bbde31a4cd1920961413a7db950e9fc530fec180de877eb37984bac8603033aa5a582e68e7f4c4ac2a10721c6630
DIST molecule-5.1.0.tar.gz 335161 BLAKE2B 55c2f3c181bef6ab848cf7b52b19649fd861dbdbd68b92d3de9e0a1330755b9b887affd8f78e92ab33145ed60e7131d3cf1ffb7b4d8f10c1c3cab8dd58288af9 SHA512 4d025a512e3a6ac7f424318f06bb23b2c1ef1cc122d31d012430bfccf4efeeb3c7ddf2450abd78378c1c50f54fffb1fa8f366f14eebe58125f177ced8cec3ff5
diff --git a/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild b/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild
deleted file mode 100644
index e648d8f91384..000000000000
--- a/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYPI_PN="molecule"
-
-inherit distutils-r1 optfeature pypi
-
-DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
-HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~riscv"
-IUSE="selinux"
-
-RDEPEND="$(python_gen_cond_dep '
- >=dev-python/ansible-compat-2.2.0[${PYTHON_USEDEP}]
- dev-python/cerberus[${PYTHON_USEDEP}]
- >=dev-python/click-8.0[${PYTHON_USEDEP}]
- >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
- selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
-')"
-BDEPEND="$(python_gen_cond_dep '
- >=dev-python/setuptools-scm-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.1[${PYTHON_USEDEP}]
- doc? (
- app-admin/ansible-core[${PYTHON_USEDEP}]
- dev-python/ansible-pygments[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.17.2[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/ansi2html-1.6.0[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- <dev-python/pexpect-5[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.3.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-testinfra-6.1.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
- dev-util/yamllint
- )
-')"
-
-# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
-# - quite a few of these tests use the network;
-# - test_command_dependency[shell] only works if Molecule has previously been installed;
-# - tests involving creation of a new scenario fail on ansible-lint errors, even though
-# a config file is deployed which should skip expected issues.
-EPYTEST_DESELECT=(
- src/molecule/test/functional/test_command.py
- src/molecule/test/unit/command/init/test_role.py
-)
-
-distutils_enable_sphinx docs '>=dev-python/sphinx-notfound-page-0.7.1' '<dev-python/sphinx_ansible_theme-0.10.0'
-distutils_enable_tests pytest
-
-pkg_postinst() {
- optfeature_header "Some optional packages commonly used in Molecule scenarios:"
- optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
-}