summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-05-30 14:07:50 -0500
committerBen Kohler <bkohler@gentoo.org>2022-05-30 14:12:46 -0500
commiteba214f3e68e625d78c898310d827beea95a4383 (patch)
treef6992c7366955a3283ee04262f20ce41264a03a8
parentdev-util/buildbot-worker: PEP 517 updates, fix missing test dep (diff)
downloadgentoo-eba214f3.tar.gz
gentoo-eba214f3.tar.bz2
gentoo-eba214f3.zip
net-proxy/tinyproxy: add 1.11.1
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--net-proxy/tinyproxy/Manifest1
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.11.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/net-proxy/tinyproxy/Manifest b/net-proxy/tinyproxy/Manifest
index f53d028c839d..f461e39056ea 100644
--- a/net-proxy/tinyproxy/Manifest
+++ b/net-proxy/tinyproxy/Manifest
@@ -1 +1,2 @@
DIST tinyproxy-1.11.0.tar.xz 177664 BLAKE2B 6ea74ef0fff22fbc6e04b37519151fda771a7d3e789d94cbd2a77a76dce7b16151cfbad83ac665a5c1fdb7334cd4d26ed6d2bc73f70b3858ffe439b16698fd2e SHA512 c0ff2a90da2352e6021efc87d1293b85f2a7588b2a1ab13bd96d906382eda8188b22b01f9acb2d200fd570bf3ec9484fa370cae6834d1f055c0af1631d22ae9d
+DIST tinyproxy-1.11.1.tar.xz 182080 BLAKE2B d39fa1986343af60cdfd07c6a049962e646a72874f7058fd082b9758bae3c7bc1a2288103527e0e1054ab098a3a41fc67eb3e08cd160e2bd4bd030e114326a6f SHA512 2e3435bbfece3797c11ccce222eef494ed92e00dd82bea2c40a54e454b7e03c8abc8e09b244f2da7192209c39047369439d08974b79eebc996fb3095230d0374
diff --git a/net-proxy/tinyproxy/tinyproxy-1.11.1.ebuild b/net-proxy/tinyproxy/tinyproxy-1.11.1.ebuild
new file mode 100644
index 000000000000..6c987419d72d
--- /dev/null
+++ b/net-proxy/tinyproxy/tinyproxy-1.11.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd tmpfiles
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A lightweight HTTP/SSL proxy"
+HOMEPAGE="https://github.com/tinyproxy/tinyproxy/"
+SRC_URI="https://github.com/tinyproxy/tinyproxy/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="test debug +filter-proxy reverse-proxy transparent-proxy
++upstream-proxy +xtinyproxy-header"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( xtinyproxy-header )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DEPEND="
+ acct-group/tinyproxy
+ acct-user/tinyproxy
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s|nobody|${PN}|g" \
+ etc/${PN}.conf.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable filter-proxy filter) \
+ $(use_enable reverse-proxy reverse) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable upstream-proxy upstream) \
+ $(use_enable xtinyproxy-header xtinyproxy) \
+ --localstatedir=/var
+}
+
+src_test() {
+ # The make check target does not run the test suite
+ emake test
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ diropts -m0775 -o ${PN} -g ${PN}
+ keepdir /var/log/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-1.10.0.initd tinyproxy
+ systemd_newunit "${FILESDIR}"/${PN}-1.10.0.service tinyproxy.service
+ dotmpfiles "${FILESDIR}"/${PN}.tmpfiles.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.tmpfiles.conf
+
+ elog "For filtering domains and URLs, enable filter option in the configuration"
+ elog "file and add them to the filter file (one domain or URL per line)."
+}