summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlarig Le Lay <alarig@swordarmor.fr>2020-05-08 20:23:28 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-06-14 13:59:14 +0300
commitebb3f3e5b75db303953c6e5ea609a7f066ef0507 (patch)
tree6b588e200a294e186c2556fd7342f718bee3e187
parentdev-python/configshell-fb: version bump to 1.1.28 (diff)
downloadgentoo-ebb3f3e5b75db303953c6e5ea609a7f066ef0507.tar.gz
gentoo-ebb3f3e5b75db303953c6e5ea609a7f066ef0507.tar.bz2
gentoo-ebb3f3e5b75db303953c6e5ea609a7f066ef0507.zip
net-dialup/freeradius-client: Switching to EAPI 7
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr> Closes: https://github.com/gentoo/gentoo/pull/15716 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild48
-rw-r--r--net-dialup/freeradius-client/metadata.xml34
2 files changed, 70 insertions, 12 deletions
diff --git a/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild b/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..f9ac8661b098
--- /dev/null
+++ b/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="FreeRADIUS Client framework"
+HOMEPAGE="https://wiki.freeradius.org/project/Radiusclient"
+SRC_URI="ftp://ftp.freeradius.org/pub/freeradius/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="scp shadow static-libs"
+
+DEPEND="!net-dialup/radiusclient-ng"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ BUGS doc/{ChangeLog,login.example,release-method.txt,instop.html}
+ README.{radexample,rst}
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die \
+ "Renaming configure.in to configure.ac failed"
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable scp)
+ $(use_enable shadow)
+ --with-secure-path
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newdoc doc/README README.login.example
+
+ use static-libs || \
+ find "${ED}" -name '*.a' -delete
+}
diff --git a/net-dialup/freeradius-client/metadata.xml b/net-dialup/freeradius-client/metadata.xml
index 2a085401d81d..597f77ab7b7f 100644
--- a/net-dialup/freeradius-client/metadata.xml
+++ b/net-dialup/freeradius-client/metadata.xml
@@ -1,16 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>FreeRADIUS Client is a framework and library for writing
-RADIUS Clients which additionally includes radlogin, a flexible RADIUS
-aware login replacement, a command line program to send RADIUS accounting
-records, a utility allowing to send RADIUS AAA requests from command
-line or from shell scripts and a utility to query the status of a (Merit)
-RADIUS server.</longdescription>
-<use>
- <flag name="scp">Add service type hints derived from username
- prefix</flag>
- <flag name="shadow">Enable shadow password support</flag>
-</use>
+ <maintainer type="person">
+ <email>alarig@swordarmor.fr</email>
+ <name>Alarig Le Lay</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ FreeRADIUS Client is a framework and library for writing RADIUS Clients
+ which additionally includes radlogin, a flexible RADIUS aware login
+ replacement, a command line program to send RADIUS accounting records, a
+ utility allowing to send RADIUS AAA requests from command line or from
+ shell scripts and a utility to query the status of a (Merit) RADIUS
+ server.
+ </longdescription>
+ <use>
+ <flag name="scp">
+ Add service type hints derived from username prefix
+ </flag>
+ <flag name="shadow">Enable shadow password support</flag>
+ </use>
</pkgmetadata>