summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-20 23:15:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-20 23:15:57 +0200
commitebba800def92f8ed075f59d0446aeca7ec09b670 (patch)
tree606010134ae8077a8dea4de5ea4494da39a2a165
parentdev-python/cvxopt: Bump to 1.2.7 (diff)
downloadgentoo-ebba800d.tar.gz
gentoo-ebba800d.tar.bz2
gentoo-ebba800d.zip
dev-python/tqdm: Bump to 4.62.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.62.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index b10a2a36e08c..81515e7c8955 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,2 +1,3 @@
DIST tqdm-4.62.0.tar.gz 169668 BLAKE2B 64a3df2f00a4fcba6bb67ae15e04f392a73b54cf7284f3c013ad31d00317e9d84ac2e1feed302137aeb7ea9e3c9d1d730623cbd96e8c76c46df6382435146efa SHA512 dd60d5522b68086410ec5f02574477dcc33a887ef509cc1d1735921dd906f951180d6115680517b3abbd2cf6c4ee1c60b9c950654ea9b7642d52d28052326088
DIST tqdm-4.62.2.tar.gz 169564 BLAKE2B fd3484db22eda5db7431fc337e23cfcf44882efc56c8b10208d799c156fefb5aa70c69c7063315d86d3ff881b97b62ac0b5c8be73ad3546ad0728f3f544cadfa SHA512 a59a041fa239e215e541f07c66292c27bfe067f3f2eac2916662b4ef1faa630346dec9558a7f66a3456b3d2ddcd164f9381cb89e5ac8350d0295367bfc248a8c
+DIST tqdm-4.62.3.tar.gz 167952 BLAKE2B d5732fc97256e1fc4f55bd1a0f69f98a87e7132cc1d8484baa12b7615da5a95ce20268515539c595c2b2aaf20f9a9434c17d581b3b90ea3cad3515150e469471 SHA512 1083ca2080163c98bbb55e124ce9d47c790e47c83cd8dad60e4c93773d1d97a50aacb5a25ddb8a2ae3691738e4f4942c88d55dab406c3e810cac18b8929d20ee
diff --git a/dev-python/tqdm/tqdm-4.62.3.ebuild b/dev-python/tqdm/tqdm-4.62.3.ebuild
new file mode 100644
index 000000000000..be993f734871
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.62.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ epytest --ignore 'tests/tests_perf.py'
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}