summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 19:25:32 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:15:14 -0600
commitebcb31b08cc8f6d49477d44458483a4c9396eb26 (patch)
treed1f1c8db0565790da5b056fe2b09bbfbef2e4932
parentdev-python/oslo-i18n: bup (diff)
downloadgentoo-ebcb31b0.tar.gz
gentoo-ebcb31b0.tar.bz2
gentoo-ebcb31b0.zip
dev-python/pycadf: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/pycadf/Manifest1
-rw-r--r--dev-python/pycadf/pycadf-2.5.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pycadf/Manifest b/dev-python/pycadf/Manifest
index 81d328c8bc67..1ee0ab99a4ee 100644
--- a/dev-python/pycadf/Manifest
+++ b/dev-python/pycadf/Manifest
@@ -1,2 +1,3 @@
DIST pycadf-2.2.0.tar.gz 246623 SHA256 bdb3427a28d318c6ce073b54993c2f4cc9148be498b30ad1b362ade45eb4f7fb SHA512 366e30b387ec1164aa52f1f79141263ea411313ff06f72de753f316ba1c0cd1b751633cd899383ba375747903c531976938d8c0733a25340a85d2b5d61d0425d WHIRLPOOL 6e9be54670196a35fe6f0c4a95429bb24947332e7fd8aaa9d99af9a57e9174cd60befe1d2a8a1a8e2d69debae67b1d23d6369ada543dda42e906913b9efa00a2
DIST pycadf-2.4.0.tar.gz 246975 SHA256 fb6100fd5cb9060b1baac1307b3cdeab0b4c5c363bce86dd712441b46dc9d793 SHA512 d0077d5c47115f9d1e2b20660c304b25ad0cb1437555ff5c9d676c1ae10b86f6155c20b37f30a0985440ec2074c2f21921c79315dfa4d42d38b640fad6ccac68 WHIRLPOOL 6cbb3805b6e2b8717381092e9d98298ad422d5809938f95f6785860e03a9e00e0c497a64ad903c2dbbef629c585a066de7f758ebf7334d5bfa4fc582be1fee7a
+DIST pycadf-2.5.0.tar.gz 247779 SHA256 a5cbf899266ea25e62e927a31dbf13607f9ebfe1525b4ec95256afc42f43be70 SHA512 af3d7676e671ed702a84052589be7146406c2c53ebfb1ee5922bec93664fac461514c832ce9f225d52a9c6b08ec330e17c5763bee6eda7a931b5dc0af6e57ed5 WHIRLPOOL 75116d8b5d669132d33bdb9f4648c4ce276b25f41dd81e10efa1e0521a0fe7cd4dc3dd95f1786aaf84014534f30cf98544df3800bfe86062db4ed5f2adf944f9
diff --git a/dev-python/pycadf/pycadf-2.5.0.ebuild b/dev-python/pycadf/pycadf-2.5.0.ebuild
new file mode 100644
index 000000000000..8f046e4c7b7f
--- /dev/null
+++ b/dev-python/pycadf/pycadf-2.5.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="python implementation of DMTF Cloud Audit (CADF) data model"
+HOMEPAGE="https://pypi.python.org/pypi/pycadf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_test() {
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}