summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-18 23:58:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-19 00:24:48 +0200
commitebf74da77d3d4642fdbce64e806b2585c965da39 (patch)
treeffa1d8815bba73f60097e83b11b9a3371d2d1601
parent*/*: dekeyword net-libs/webkit-gtk and revdeps on alpha (diff)
downloadgentoo-ebf74da77d3d4642fdbce64e806b2585c965da39.tar.gz
gentoo-ebf74da77d3d4642fdbce64e806b2585c965da39.tar.bz2
gentoo-ebf74da77d3d4642fdbce64e806b2585c965da39.zip
kde-misc/tellico: Prioritise local copy of FindTaglib.cmake
Fixes build with ECM 5.72 which ships a newer incompatible version. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-misc/tellico/files/tellico-3.3.1-kf-5.72-findtaglib.patch28
-rw-r--r--kde-misc/tellico/tellico-3.3.1.ebuild2
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-misc/tellico/files/tellico-3.3.1-kf-5.72-findtaglib.patch b/kde-misc/tellico/files/tellico-3.3.1-kf-5.72-findtaglib.patch
new file mode 100644
index 000000000000..5d77a9816ba0
--- /dev/null
+++ b/kde-misc/tellico/files/tellico-3.3.1-kf-5.72-findtaglib.patch
@@ -0,0 +1,28 @@
+From 1051b34db65a45a4fd5f12cad0eebc27325a2be3 Mon Sep 17 00:00:00 2001
+From: Jonathan Riddell <jr@jriddell.org>
+Date: Fri, 19 Jun 2020 15:35:08 +0100
+Subject: [PATCH] switch order of cmake modules so it gives priority to the
+ local copy which will be the one it expects. fixes build failure on KDE neon
+
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 00ee0035..5b96f25b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -20,8 +20,8 @@ endif(POLICY CMP0063)
+ set(CMAKE_INCLUDE_CURRENT_DIR TRUE)
+
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH}
+- ${ECM_MODULE_PATH}
+- ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
++ ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules
++ ${ECM_MODULE_PATH})
+
+ #include(ECMAddTests)
+ #include(ECMMarkNonGuiExecutable)
+--
+GitLab
+
diff --git a/kde-misc/tellico/tellico-3.3.1.ebuild b/kde-misc/tellico/tellico-3.3.1.ebuild
index f39a4200a144..28dc136aec56 100644
--- a/kde-misc/tellico/tellico-3.3.1.ebuild
+++ b/kde-misc/tellico/tellico-3.3.1.ebuild
@@ -71,6 +71,8 @@ DEPEND="${RDEPEND}"
# tests need network access
RESTRICT+=" test"
+PATCHES=( "${FILESDIR}/${P}-kf-5.72-findtaglib.patch" )
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Csv=ON