summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-26 19:26:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-26 19:26:30 +0200
commitebfac4c84963d6453b527c2380310c01a45be403 (patch)
treef66525ddc4b0accf456f47433172badb938210a6
parentdev-python/fixtures: Bump to 4.1.0 (diff)
downloadgentoo-ebfac4c84963d6453b527c2380310c01a45be403.tar.gz
gentoo-ebfac4c84963d6453b527c2380310c01a45be403.tar.bz2
gentoo-ebfac4c84963d6453b527c2380310c01a45be403.zip
dev-python/roman: Bump to 4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/roman/Manifest1
-rw-r--r--dev-python/roman/roman-4.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/roman/Manifest b/dev-python/roman/Manifest
index 4c41008b291a..ea2805cf9a8c 100644
--- a/dev-python/roman/Manifest
+++ b/dev-python/roman/Manifest
@@ -1 +1,2 @@
DIST roman-4.0.tar.gz 9380 BLAKE2B f158a9c7ed9aae2e8c3aaf8b4db9610cd437119493af87c248f8f7d2157228f2bbeb7085eb8f02d169f3e3f5221831ebb10a773d70c5dc7133d32896d5c21dbd SHA512 5421ac46fc5f49c8913a6089d51781bc0a01f2863ea2655b57adba1d07632d4e459fcb26350d0c2dfdf4a31c64a31e9fc86b22165df212c9f8db4bf41cf2e2a1
+DIST roman-4.1.tar.gz 7005 BLAKE2B de3e7dc4e05994f906b357d8db2f1149f3bf9f420552220cf1cf9427a8ae63ed3ba873b28b75dcbc1f675a370354efa5cae3ac9fb070f9b02126a2867bcefb07 SHA512 69214f35098e17bd106411036feec8a4e5c8450e394c74d60a8e3cc17c6884556347a1d2852fa174db4f66d969e71b26c066439afd6d278786d1a47bf925f302
diff --git a/dev-python/roman/roman-4.1.ebuild b/dev-python/roman/roman-4.1.ebuild
new file mode 100644
index 000000000000..202ec5b2071c
--- /dev/null
+++ b/dev-python/roman/roman-4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An Integer to Roman numerals converter"
+HOMEPAGE="
+ https://pypi.org/project/roman/
+ https://github.com/zopefoundation/roman
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ mv "${S}/src/tests.py" . || die "moving test file failed"
+ distutils-r1_python_prepare_all
+}