summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-11 06:17:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 07:17:57 +0200
commitec3289cab4046831ccb4ff9594f71668faf3a9a7 (patch)
tree088fa1dfbad4f7d73a05a87bb2d2a585f4542792
parentdev-python/argcomplete: Bump to 3.1.0 (diff)
downloadgentoo-ec3289cab4046831ccb4ff9594f71668faf3a9a7.tar.gz
gentoo-ec3289cab4046831ccb4ff9594f71668faf3a9a7.tar.bz2
gentoo-ec3289cab4046831ccb4ff9594f71668faf3a9a7.zip
dev-python/tokenize-rt: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tokenize-rt/Manifest1
-rw-r--r--dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/tokenize-rt/Manifest b/dev-python/tokenize-rt/Manifest
index 40c12e3c1006..7b7bf0250f85 100644
--- a/dev-python/tokenize-rt/Manifest
+++ b/dev-python/tokenize-rt/Manifest
@@ -1 +1,2 @@
DIST tokenize-rt-5.0.0.gh.tar.gz 7235 BLAKE2B d5e5dd3637615c451463d85e63b6d48670ed18de58e111625b106cfc0af2616726d2ff510412decd32db2c67dea5807d5f9b64ecfa902f56fd32b739085698c3 SHA512 03e609b1a951e62fed797a10aad1813d324c96019bdf1ad0e413b278d04395d8c4e0d2f10189309338524d928b33441a1c0141cce922f25b9f8c2764415475f3
+DIST tokenize-rt-5.1.0.gh.tar.gz 7090 BLAKE2B 4ba6ad24c9cae7f077ae84cc43a5836e282fa2eae5cc1b93c717cf79d5d2afdd2801be0724c08710d88429b4f289086764e0b98533e9d120d66deb8499a8f022 SHA512 a09101eb94479d8e1a22c8976915c41bea1d193091aee9cbb7019846ff667aaa895ff2f9faa9ffa1fdf4ad4c31a76425e89c7aa46e0c16750f15cca117249b94
diff --git a/dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild b/dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild
new file mode 100644
index 000000000000..6cee68230e71
--- /dev/null
+++ b/dev-python/tokenize-rt/tokenize-rt-5.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around the stdlib 'tokenize' which roundtrips"
+HOMEPAGE="
+ https://github.com/asottile/tokenize-rt/
+ https://pypi.org/project/tokenize-rt/
+"
+SRC_URI="
+ https://github.com/asottile/tokenize-rt/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+distutils_enable_tests pytest