summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-30 19:42:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-30 19:51:27 +0200
commitec3f263f816b8b6f9f65531ed3080d5f48fe9f92 (patch)
tree8cde317da52f62950680d161fbb6e6dc473907b1
parentdev-python/pypdf: Bump to 3.14.0 (diff)
downloadgentoo-ec3f263f816b8b6f9f65531ed3080d5f48fe9f92.tar.gz
gentoo-ec3f263f816b8b6f9f65531ed3080d5f48fe9f92.tar.bz2
gentoo-ec3f263f816b8b6f9f65531ed3080d5f48fe9f92.zip
dev-python/xxhash: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xxhash/Manifest1
-rw-r--r--dev-python/xxhash/xxhash-3.3.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/xxhash/Manifest b/dev-python/xxhash/Manifest
index 2a51c4bd01f3..5c2639f65c74 100644
--- a/dev-python/xxhash/Manifest
+++ b/dev-python/xxhash/Manifest
@@ -1 +1,2 @@
DIST xxhash-3.2.0.tar.gz 74561 BLAKE2B d2c32b9a556eaaa67d961e130b017ff82944fbec983f24e0356436a7a23927faaba118328eff508e288e0757a1379b5ff88a48c2130eb9b3cf347e178cfc810d SHA512 bbe903b95de3e91177064986adc5c945a9b7058650ea2b5cc10ee162a15a42909dc69f95b86081b8d276960f309b4bacf895ad263a9d9188fa66bb216d76dcd5
+DIST xxhash-3.3.0.tar.gz 84262 BLAKE2B 9655bed8c30e8ecc7b3f12bebe9f845412e4fbc24daef11570eb8bf78deaf78fe4ea874a5ed334c965c055e6ad4e32f03f025d3ed815bb7a2249e8f80a0b04b0 SHA512 1418e0ff8d7dca7759bfe048ee42c2b1168b68ec69f431622f065c28bcf65b2e21f5951a8651f2151a17f8d1b19b47d5c305a545ae1e0d427c7cadf29e94b968
diff --git a/dev-python/xxhash/xxhash-3.3.0.ebuild b/dev-python/xxhash/xxhash-3.3.0.ebuild
new file mode 100644
index 000000000000..4839bd405feb
--- /dev/null
+++ b/dev-python/xxhash/xxhash-3.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python binding for the xxHash library"
+HOMEPAGE="
+ https://github.com/ifduyue/python-xxhash/
+ https://pypi.org/project/xxhash/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/xxhash-0.8.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ export XXHASH_LINK_SO=1
+}
+
+python_test() {
+ cd tests || die
+ eunittest
+}