summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-03 01:41:23 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-03 01:41:23 +0100
commitec4e028db754e7698efdcccd1194b19246881d18 (patch)
treec0ee3f23bd58fe52c7fe80d81d237848e0513fa9
parentsci-astronomy/weightwatcher: Initial import (diff)
downloadgentoo-ec4e028d.tar.gz
gentoo-ec4e028d.tar.bz2
gentoo-ec4e028d.zip
app-office/libreoffice-bin-debug: Revbump to relax graphite2 dependencies
Package-Manager: portage-2.2.27
-rw-r--r--app-office/libreoffice-bin-debug/libreoffice-bin-debug-5.0.5.2-r1.ebuild (renamed from app-office/libreoffice-bin-debug/libreoffice-bin-debug-5.0.5.2.ebuild)38
1 files changed, 19 insertions, 19 deletions
diff --git a/app-office/libreoffice-bin-debug/libreoffice-bin-debug-5.0.5.2.ebuild b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-5.0.5.2-r1.ebuild
index 4d54b26242c2..7b97ca35f313 100644
--- a/app-office/libreoffice-bin-debug/libreoffice-bin-debug-5.0.5.2.ebuild
+++ b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-5.0.5.2-r1.ebuild
@@ -11,31 +11,31 @@ BASE_X86_URI="http://packages.gentooexperimental.org/packages/x86-libreoffice/x8
DESCRIPTION="LibreOffice, a full office productivity suite. Binary package, debug info"
HOMEPAGE="http://www.libreoffice.org"
SRC_URI_AMD64="
- ${BASE_AMD64_URI}libreoffice-${PVR}.tar.xz
+ ${BASE_AMD64_URI}libreoffice-${PV}.tar.xz
kde? (
- !java? ( ${BASE_AMD64_URI}libreoffice-kde-${PVR}.xd3 )
- java? ( ${BASE_AMD64_URI}libreoffice-kde-java-${PVR}.xd3 )
+ !java? ( ${BASE_AMD64_URI}libreoffice-kde-${PV}.xd3 )
+ java? ( ${BASE_AMD64_URI}libreoffice-kde-java-${PV}.xd3 )
)
gnome? (
- !java? ( ${BASE_AMD64_URI}libreoffice-gnome-${PVR}.xd3 )
- java? ( ${BASE_AMD64_URI}libreoffice-gnome-java-${PVR}.xd3 )
+ !java? ( ${BASE_AMD64_URI}libreoffice-gnome-${PV}.xd3 )
+ java? ( ${BASE_AMD64_URI}libreoffice-gnome-java-${PV}.xd3 )
)
!kde? ( !gnome? (
- java? ( ${BASE_AMD64_URI}libreoffice-java-${PVR}.xd3 )
+ java? ( ${BASE_AMD64_URI}libreoffice-java-${PV}.xd3 )
) )
"
SRC_URI_X86="
- ${BASE_X86_URI}libreoffice-${PVR}.tar.xz
+ ${BASE_X86_URI}libreoffice-${PV}.tar.xz
kde? (
- !java? ( ${BASE_X86_URI}libreoffice-kde-${PVR}.xd3 )
- java? ( ${BASE_X86_URI}libreoffice-kde-java-${PVR}.xd3 )
+ !java? ( ${BASE_X86_URI}libreoffice-kde-${PV}.xd3 )
+ java? ( ${BASE_X86_URI}libreoffice-kde-java-${PV}.xd3 )
)
gnome? (
- !java? ( ${BASE_X86_URI}libreoffice-gnome-${PVR}.xd3 )
- java? ( ${BASE_X86_URI}libreoffice-gnome-java-${PVR}.xd3 )
+ !java? ( ${BASE_X86_URI}libreoffice-gnome-${PV}.xd3 )
+ java? ( ${BASE_X86_URI}libreoffice-gnome-java-${PV}.xd3 )
)
!kde? ( !gnome? (
- java? ( ${BASE_X86_URI}libreoffice-java-${PVR}.xd3 )
+ java? ( ${BASE_X86_URI}libreoffice-java-${PV}.xd3 )
) )
"
@@ -60,8 +60,8 @@ S="${WORKDIR}"
QA_PREBUILT="/usr/*"
src_unpack() {
- einfo "Uncompressing distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar.xz"
- xz -cd "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar.xz" > "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" || die
+ einfo "Uncompressing distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar.xz"
+ xz -cd "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar.xz" > "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar" || die
local patchname
use kde && patchname="-kde"
@@ -69,13 +69,13 @@ src_unpack() {
use java && patchname="${patchname}-java"
if [ -n "${patchname}" ]; then
- einfo "Patching distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar using ${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3"
- xdelta3 -d -s "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3" "${WORKDIR}/tmpdist.tar" || die
- mv "${WORKDIR}/tmpdist.tar" "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" || die
+ einfo "Patching distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar using ${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PV}.xd3"
+ xdelta3 -d -s "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar" "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PV}.xd3" "${WORKDIR}/tmpdist.tar" || die
+ mv "${WORKDIR}/tmpdist.tar" "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar" || die
fi
- einfo "Unpacking new ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar"
- unpack "./${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar"
+ einfo "Unpacking new ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar"
+ unpack "./${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar"
}
src_configure() { :; }