summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-03 11:19:55 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-03 11:41:04 +0200
commitec6f2b0f5a236b6675aa448480bb29ae31e27cba (patch)
tree3e0d7aa3a2ef786a85b6081e8af0b9490f717de4
parentmedia-libs/libjpeg-turbo: marked ~arm64-macos (diff)
downloadgentoo-ec6f2b0f5a236b6675aa448480bb29ae31e27cba.tar.gz
gentoo-ec6f2b0f5a236b6675aa448480bb29ae31e27cba.tar.bz2
gentoo-ec6f2b0f5a236b6675aa448480bb29ae31e27cba.zip
dev-ruby/rqrcode: add 2.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rqrcode/Manifest1
-rw-r--r--dev-ruby/rqrcode/rqrcode-2.2.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/rqrcode/Manifest b/dev-ruby/rqrcode/Manifest
index 148dd3e5aa08..571e8293a727 100644
--- a/dev-ruby/rqrcode/Manifest
+++ b/dev-ruby/rqrcode/Manifest
@@ -1 +1,2 @@
DIST rqrcode-2.1.2.tar.gz 108650 BLAKE2B 61fdb8d2c5dde83062b53551932d74db40d6fec4245afeafd9f656a1dffeee7842fb27f750d115843642fa68305cc6af08a48764a59d8912ec759a11a3858d2f SHA512 b037416073c06a13fa1aebed63a9f07e9302ace7bb3a53015a296c1317cc284d680e6e8f93ae295ddf19cc90a74857467389d15cae1606207f039dde301e59da
+DIST rqrcode-2.2.0.tar.gz 109070 BLAKE2B 91a74a9c547f62f0cd83dd60d00b7af2c9363bd34f3987e43b637f906975f3e2b1f95ac67df80a0065fdd9fa3a7801e639fff1d2b36bcc4dc4abbc996fb6c919 SHA512 41d6882b28d15154b9cc5dc6aba30cad404aabad2b9101309bea0812b776cdb540fec3152ec5bb075f19c77a1aa67bc44d9b35e2161d189bd64a7d2517cafa63
diff --git a/dev-ruby/rqrcode/rqrcode-2.2.0.ebuild b/dev-ruby/rqrcode/rqrcode-2.2.0.ebuild
new file mode 100644
index 000000000000..84f7f4b7259d
--- /dev/null
+++ b/dev-ruby/rqrcode/rqrcode-2.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rqrcode.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="https://whomwah.github.io/rqrcode/"
+SRC_URI="https://github.com/whomwah/rqrcode/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/chunky_png:0
+ dev-ruby/rqrcode_core:1
+"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}