summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-09 18:23:15 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-09 18:23:15 +0100
commitec9337aa72f4599ed92d23c6d26a6c1711348637 (patch)
tree8848793dc0b342ef347d4239dcf0be3283c6d26a
parentapp-editors/ng: Fixed build with sys-libs/ncurses[tinfo] (diff)
downloadgentoo-ec9337aa72f4599ed92d23c6d26a6c1711348637.tar.gz
gentoo-ec9337aa72f4599ed92d23c6d26a6c1711348637.tar.bz2
gentoo-ec9337aa72f4599ed92d23c6d26a6c1711348637.zip
net-misc/liveice: Fixed build with sys-libs/ncurses[tinfo]
Closes: https://bugs.gentoo.org/690328 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-misc/liveice/files/liveice-2000530-build.patch38
-rw-r--r--net-misc/liveice/liveice-2000530-r2.ebuild18
2 files changed, 46 insertions, 10 deletions
diff --git a/net-misc/liveice/files/liveice-2000530-build.patch b/net-misc/liveice/files/liveice-2000530-build.patch
new file mode 100644
index 000000000000..14ab084c3d06
--- /dev/null
+++ b/net-misc/liveice/files/liveice-2000530-build.patch
@@ -0,0 +1,38 @@
+--- liveice/configure.in
++++ liveice/configure.in
+@@ -39,6 +39,7 @@
+
+ dnl Replace `main' with a function in -lresolv:
+ AC_CHECK_LIB(curses, refresh)
++AC_SEARCH_LIBS(nodelay, tinfo ncurses curses)
+
+
+ dnl Checks for header files.
+--- liveice/Makefile.in
++++ liveice/Makefile.in
+@@ -1,6 +1,6 @@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+-LDFLAGS = @LIBS@
++LIBS = @LIBS@
+ SHELL=/bin/sh
+
+ srcdir = @srcdir@
+@@ -18,7 +18,7 @@
+
+ DEFS = -I. @DEFS@
+
+-COMPILE_CFLAGS=$(CFLAGS) $(DEFS)
++COMPILE_CFLAGS=$(CFLAGS) $(LDFLAGS) $(DEFS)
+
+ .PHONY: clean distclean install installdirs
+
+@@ -33,7 +33,7 @@
+ rm -f Makefile configure config.log config.cache config.h config.status
+
+ liveice: setup.o streams.o encoders.o serverlib.o mpeg.o mixer.o display.o playlist.o wav.o audio_proc.o controls.o meta_data.o url.o liveice.h liveice.c
+- $(CC) $(COMPILE_CFLAGS) -o liveice $(OBJS) $(LDFLAGS) liveice.c
++ $(CC) $(COMPILE_CFLAGS) -o liveice $(OBJS) $(LIBS) liveice.c
+
+ setup.o: setup.c
+ $(CC) $(COMPILE_CFLAGS) -c -o setup.o setup.c
diff --git a/net-misc/liveice/liveice-2000530-r2.ebuild b/net-misc/liveice/liveice-2000530-r2.ebuild
index ab5dbb3d5095..9b714278e0a2 100644
--- a/net-misc/liveice/liveice-2000530-r2.ebuild
+++ b/net-misc/liveice/liveice-2000530-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Live Source Client For IceCast"
HOMEPAGE="http://star.arm.ac.uk/~spm/software/liveice.html"
@@ -17,20 +17,18 @@ RDEPEND="media-sound/lame
media-sound/mpg123"
DEPEND=""
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
src_prepare() {
default
- # cannot use LDFLAGS directly as the Makefile uses it for LIBS
- sed -i Makefile.in \
- -e 's|-o liveice|$(LLFLAGS) &|' \
- || die "sed Makefile.in"
+ eautoreconf
tc-export CC
}
-src_compile() {
- emake LLFLAGS="${LDFLAGS}"
-}
src_install() {
dobin liveice
dodoc liveice.cfg README.liveice README.quickstart README_new_mixer.txt Changes.txt