summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-27 03:44:42 +0000
committerSam James <sam@gentoo.org>2024-03-27 03:45:39 +0000
commitec95eaffca8731e4604cacefe2fabc4b814f7a9c (patch)
tree187aa28099b58eaa12f79cdde75e4b7fa79ac89f
parentsys-devel/clang-common: Require new enough lld version (diff)
downloadgentoo-ec95eaffca8731e4604cacefe2fabc4b814f7a9c.tar.gz
gentoo-ec95eaffca8731e4604cacefe2fabc4b814f7a9c.tar.bz2
gentoo-ec95eaffca8731e4604cacefe2fabc4b814f7a9c.zip
virtual/rust: backport USE=profiler
This makes life easier for Chromium which we're about to stable. Bug: https://bugs.gentoo.org/923010 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--profiles/arch/loong/package.use.mask4
-rw-r--r--profiles/arch/s390/package.use.mask4
-rw-r--r--virtual/rust/rust-1.71.0-r2.ebuild (renamed from virtual/rust/rust-1.71.0-r1.ebuild)8
-rw-r--r--virtual/rust/rust-1.71.1-r2.ebuild (renamed from virtual/rust/rust-1.71.1-r1.ebuild)8
-rw-r--r--virtual/rust/rust-1.73.0-r1.ebuild (renamed from virtual/rust/rust-1.73.0.ebuild)8
-rw-r--r--virtual/rust/rust-1.74.1-r1.ebuild (renamed from virtual/rust/rust-1.74.1.ebuild)6
-rw-r--r--virtual/rust/rust-1.75.0-r1.ebuild (renamed from virtual/rust/rust-1.75.0.ebuild)6
-rw-r--r--virtual/rust/rust-1.76.0.ebuild2
8 files changed, 27 insertions, 19 deletions
diff --git a/profiles/arch/loong/package.use.mask b/profiles/arch/loong/package.use.mask
index 8b3a6e04f5ce..5a4cfa839690 100644
--- a/profiles/arch/loong/package.use.mask
+++ b/profiles/arch/loong/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Sam James <sam@gentoo.org> (2024-03-27)
+# No rust-bin available for profiler
+<virtual/rust-1.73.0 profiler
+
# Robin H. Johnson <robbat2@gentoo.org) (2024-03-13)
# sys-cluster/corosync not yet keyworded, niche use case for mdadm
sys-fs/mdadm corosync
diff --git a/profiles/arch/s390/package.use.mask b/profiles/arch/s390/package.use.mask
index 47877ea78dcf..7f0d5543f2ab 100644
--- a/profiles/arch/s390/package.use.mask
+++ b/profiles/arch/s390/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Sam James <sam@gentoo.org> (2024-03-27)
+# No rust-bin available for profiler
+virtual/rust profiler
+
# Eray Aslan <eras@gentoo.org> (2024-03-08)
# mongodb dependencies are not keyworded
mail-mta/postfix mongodb
diff --git a/virtual/rust/rust-1.71.0-r1.ebuild b/virtual/rust/rust-1.71.0-r2.ebuild
index 455f215fcecc..f452208a1d82 100644
--- a/virtual/rust/rust-1.71.0-r1.ebuild
+++ b/virtual/rust/rust-1.71.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,10 +14,10 @@ LICENSE=""
# neither system nor bundled, so we just hardcode it here.
SLOT="0/llvm-16"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="rustfmt"
+IUSE="profiler rustfmt"
BDEPEND=""
RDEPEND="|| (
- ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
- ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
)"
diff --git a/virtual/rust/rust-1.71.1-r1.ebuild b/virtual/rust/rust-1.71.1-r2.ebuild
index 5641e68236d4..62393a5d36f6 100644
--- a/virtual/rust/rust-1.71.1-r1.ebuild
+++ b/virtual/rust/rust-1.71.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,10 +14,10 @@ LICENSE=""
# neither system nor bundled, so we just hardcode it here.
SLOT="0/llvm-16"
KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="rustfmt"
+IUSE="profiler rustfmt"
BDEPEND=""
RDEPEND="|| (
- ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
- ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
)"
diff --git a/virtual/rust/rust-1.73.0.ebuild b/virtual/rust/rust-1.73.0-r1.ebuild
index 6662fd2eeded..36a81c55f875 100644
--- a/virtual/rust/rust-1.73.0.ebuild
+++ b/virtual/rust/rust-1.73.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,10 +14,10 @@ LICENSE=""
# neither system nor bundled, so we just hardcode it here.
SLOT="0/llvm-17"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="rustfmt"
+IUSE="profiler rustfmt"
BDEPEND=""
RDEPEND="|| (
- ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
- ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
)"
diff --git a/virtual/rust/rust-1.74.1.ebuild b/virtual/rust/rust-1.74.1-r1.ebuild
index 142a357e436a..4e9f43e5561b 100644
--- a/virtual/rust/rust-1.74.1.ebuild
+++ b/virtual/rust/rust-1.74.1-r1.ebuild
@@ -14,10 +14,10 @@ LICENSE=""
# neither system nor bundled, so we just hardcode it here.
SLOT="0/llvm-17"
KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="rustfmt"
+IUSE="profiler rustfmt"
BDEPEND=""
RDEPEND="|| (
- ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
- ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
)"
diff --git a/virtual/rust/rust-1.75.0.ebuild b/virtual/rust/rust-1.75.0-r1.ebuild
index bf56f7a58c9d..4ed48e05d316 100644
--- a/virtual/rust/rust-1.75.0.ebuild
+++ b/virtual/rust/rust-1.75.0-r1.ebuild
@@ -14,10 +14,10 @@ LICENSE=""
# neither system nor bundled, so we just hardcode it here.
SLOT="0/llvm-17"
KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="rustfmt"
+IUSE="profiler rustfmt"
BDEPEND=""
RDEPEND="|| (
- ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
- ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[profiler(-)?,rustfmt?,${MULTILIB_USEDEP}]
)"
diff --git a/virtual/rust/rust-1.76.0.ebuild b/virtual/rust/rust-1.76.0.ebuild
index 187391b93274..2790ab8f7afc 100644
--- a/virtual/rust/rust-1.76.0.ebuild
+++ b/virtual/rust/rust-1.76.0.ebuild
@@ -14,7 +14,7 @@ LICENSE=""
# neither system nor bundled, so we just hardcode it here.
SLOT="0/llvm-17"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="rustfmt profiler"
+IUSE="profiler rustfmt"
BDEPEND=""
RDEPEND="|| (