summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-15 08:25:41 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-11-17 12:59:08 -0500
commitec9ea95f5f57c7e6fb78e24de1dd7e6e9d3fb722 (patch)
treeb6c6fa1d4cdcbd7876e7e06075728b749ee6fd88
parentdev-perl/Unicode-Map8: Stabilize 0.130.0-r2 ppc64, #805089 (diff)
downloadgentoo-ec9ea95f5f57c7e6fb78e24de1dd7e6e9d3fb722.tar.gz
gentoo-ec9ea95f5f57c7e6fb78e24de1dd7e6e9d3fb722.tar.bz2
gentoo-ec9ea95f5f57c7e6fb78e24de1dd7e6e9d3fb722.zip
games-board/gnubg: enable py3.10
Technically eautoreconf could be behind `use python` (and autoconf-archive is guaranteed if python is installed), but do not want to introduce use-conditional autoconf variance (eautoreconf may also be useful for other reasons in the future). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-board/gnubg/gnubg-1.06.002-r1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/games-board/gnubg/gnubg-1.06.002-r1.ebuild b/games-board/gnubg/gnubg-1.06.002-r1.ebuild
index 67a589a1255d..a901f3ff8248 100644
--- a/games-board/gnubg/gnubg-1.06.002-r1.ebuild
+++ b/games-board/gnubg/gnubg-1.06.002-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit desktop python-single-r1 xdg
+PYTHON_COMPAT=( python3_{8..10} )
+inherit autotools desktop python-single-r1 xdg
DESCRIPTION="GNU BackGammon"
HOMEPAGE="https://www.gnu.org/software/gnubg/"
@@ -33,6 +33,7 @@ RDEPEND="
virtual/libintl"
DEPEND="${RDEPEND}"
BDEPEND="
+ sys-devel/autoconf-archive
sys-devel/gettext
virtual/pkgconfig"
@@ -45,7 +46,7 @@ src_prepare() {
# use ${T} instead of /tmp for constructing credits (bug #298275)
sed -i -e 's:/tmp:${T}:' credits.sh || die
- sed -i -e 's/fonts //' Makefile.in || die # handle font install ourself to fix bug #335774
+ sed -i -e 's/fonts //' Makefile.am || die # handle font install ourself to fix bug #335774
sed -i \
-e '/^localedir / s#=.*$#= @localedir@#' \
-e '/^gnulocaledir / s#=.*$#= @localedir@#' \
@@ -53,10 +54,15 @@ src_prepare() {
sed -i \
-e '/^gnubgiconsdir / s#=.*#= /usr/share#' \
-e '/^gnubgpixmapsdir / s#=.*#= /usr/share/pixmaps#' \
- pixmaps/Makefile.in || die
+ pixmaps/Makefile.am || die
sed -i \
-e '1i#include <config.h>' \
copying.c || die #551896
+
+ # use system's copy so py3.10 distutils warning doesn't trigger a fatal error
+ rm m4/ax_python_devel.m4 || die
+
+ eautoreconf
}
src_configure() {